Forms lost data when get documents innerHTML

RESOLVED DUPLICATE of bug 159282

Status

()

Firefox
Extension Compatibility
RESOLVED DUPLICATE of bug 159282
11 years ago
11 years ago

People

(Reporter: Micael, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.8.1) Gecko/20061010 Firefox/2.0

When use document.getElementById('DIV').innerHTML and in DIV exist one form, this data lost.

Exemple: http://www.aiatola.net/bug.html

Reproducible: Always

Steps to Reproduce:
1. Select and write any data
2. Click in 'Adicionar Formação'
3. See this form data lost.
4. In I.E. this function is correct
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 159282
You need to log in before you can comment on or make changes to this bug.