T'Bird Beta 1 RC 2 Junk Settings in Account Settings not allowing LDAP

RESOLVED DUPLICATE of bug 180012

Status

Thunderbird
Preferences
RESOLVED DUPLICATE of bug 180012
11 years ago
11 years ago

People

(Reporter: David Jackson, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

in the "Account Settings", then in "Junk Settings", there is an optiopn that states "Do not mark as junk if hte sender is in" ......   Only local address books are being displayed in the drop down list box.  I run an LDAP and this is not being allowed in the whitelist search fora valid address.

I think, this is a bug and a serious deficiency in T'Bird in not providing more support of LDAP's for the Address Book.  

Reproducible: Always

Comment 1

11 years ago
this is probably a dup.

It's hard because ldap lookups are asynchronous, and we need to know synchronously if the sender is in the ab - otherwise, we'd need to rewrite the spam filter application code.
(Assignee)

Updated

11 years ago

*** This bug has been marked as a duplicate of 180012 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

11 years ago
Sadly, based upon the age of 180012, it seems that there is little to no interest in T'Bird providing any depth of support for LDAP. Not having provided this in T'Bird Version 2 is a serious deficiency if there is any intent of spreading T'Bird to a wider audience instead of focusing on the 'home' user.  
(Assignee)

Comment 4

11 years ago
dkjackson, one of the things that makes our project special is that we're an open source project comprised of volunteers who do this in their free time. This could be a great way for you to get involved in the project by contributing a fix for this issue which is so important to you! There may be others out there just like you who would enjoy this feature. Cheers.

Comment 5

11 years ago
although this may or may not help you, you can also whitelist by domain in 2.0 - if you add your enterprise's domain to the pref "mail.trusteddomains", we'll whitelist any e-mail from that domain. This isn't ideal for lots of obvious reasons, but it may help.
You need to log in before you can comment on or make changes to this bug.