SYS_ALERT MSAA event in Firefox 2

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
12 years ago
8 years ago

People

(Reporter: deangelo, Unassigned)

Tracking

({access})

1.8 Branch
x86
Windows XP
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
Env: Test environment:
   Windows XP, Firefox 2.0 

1. Start Firefox 2 and load url: http://www.sipura.net/support/login/index.htm 
2. Type a character in the user name edit box.
3. In this situation the edit box has the immediate parent HWND as the 
standard dialog window class (#32770).  My solution to all of these 
unwanted events is to block alert events when the parent HWND is a 
#32770.   This allows Window-Eyes to read this dialog as a conventional 
Windows dialog.

I've got a couple of questions as a result:

Is it correct for Firefox 2 to send an alert event with every keypress 
in this dialog?

What are examples of other situations where an alert event is fired for 
some other reason?

Is there anything that distinguishes this alert from the others?

Comment 1

12 years ago
The problem is that the alert event is sent on every keystroke.

Updated

12 years ago
Blocks: 342901

Comment 2

12 years ago
This is definitely a bug, and is only happening in Firefox 2. It's not happening in Firefox 3. I'm not sure why right now, but since you have a workaround for now I think we won't make this a top priority.
Blocks: 333488
No longer blocks: 342901
Mass un-assigning bugs assigned to Aaron.
Assignee: aaronleventhal → nobody
wontfix per comment #2
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.