All users were logged out of Bugzilla on October 13th, 2018

Meta refresh refreshes browser even after you navigate elsewhere

VERIFIED FIXED

Status

()

P2
critical
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: jwbaker, Assigned: mscott)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+], URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Meta refresh is being honored for pages which you are no longer viewing.  This
causes Mozilla to take you away from the page you are currently viewing and back
to some page in the past.  This is i686-pc-linux-gnu Build 2000041908 (M16).  To
reproduce:

1: Start Mozilla
2: Visit http://cbs.marketwatch.com/
3: Visit http://www.yahoo.com/
4: Wait 300 seconds
5: Mozilla yanks you back to marketwatch

The expected behavior is that Mozilla does nothing.  For your bug-hunting
enjoyment, I have distilled this bug down to a tiny attachment which has a
refresh of only 15 seconds.  I will attach it next.
(Reporter)

Comment 1

19 years ago
Created attachment 7741 [details]
HTML file that demonstrates refresh problem

Comment 2

19 years ago
Same behaviour in yesterdays 2000-041816 M16 linux

Comment 3

19 years ago
Confirming this on Linux build 2000.04.19.08-M16.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

19 years ago
->jud
Assignee: gagan → valeski

Comment 5

19 years ago
this must have changed during the webshell changes. travis, the old webshell 
used to cancel any outstanding refresh timers (nsIRefresh stuff). I bet that's 
broken now.
Assignee: valeski → travis

Updated

19 years ago
Blocks: 32049

Comment 6

19 years ago
Try going to :   http://www.abika.com/wd
(sample page with 15-second refresh)

Then (within 15 seconds) type in http://www.mozilla.org

When the 15 seconds are up...   bam!  Back to the meta refresh page.


(I just figured this would be a nicer example than waiting 300 seconds at CBS
Marketwatch)

-WD
(Reporter)

Comment 7

19 years ago
Thanks for the effort wdormann@crosswinds.net, but I created a 15-second test
and attached it when the bug was originally reported :)

http://bugzilla.mozilla.org/showattachment.cgi?attach_id=7741

Comment 8

19 years ago
cc'ing myself and radha. changing platform/OS to all - this is sooo XP. and grooving for some beta2 love.
Keywords: nsbeta2
OS: Linux → All
Hardware: PC → All

Comment 9

19 years ago
*** Bug 36767 has been marked as a duplicate of this bug. ***

Comment 10

19 years ago
*** Bug 36712 has been marked as a duplicate of this bug. ***

Comment 11

19 years ago
http://tinderbox.mozilla.org/seamonkey/panel.html triggers it too (maybe with a
twist according to puetzk on irc) and has <a target='_content' ..> which might
screw up some more.

Comment 12

19 years ago
I believe this bug happens because sockets to previous visited sites aren't
being closed/killed when you leave the site. Thus "foreign" servers can
reactivate the sockets. Please see bug 35150 - marked fixed but there are still 
severe problems "if you ask me". [Related "opposite case": bug 35844]

Comment 13

19 years ago
*** Bug 37283 has been marked as a duplicate of this bug. ***

Comment 14

19 years ago
*** Bug 37283 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 15

19 years ago
Marking as dogfood. I keep getting bit in the ass by this bug. I have
mynetscape.com as my default home page that has a refresh of 5 minutes. Now,
when entering something like a bug report in bugzilla, if I'm writing a long
report, mynetscape gets loaded on top of my buzilla report and I lose my data.
Very frustrating..definetly dogfood.

Since Travis is out this week, I'll try to take a look and fix this myself.
Severity: normal → critical
Keywords: dogfood
Priority: P3 → P2
(Assignee)

Comment 16

19 years ago
I have a fix for this in my tree. I will post the patch to this bug report.
(Assignee)

Comment 17

19 years ago
Created attachment 8054 [details] [diff] [review]
fix for this bug.
(Assignee)

Comment 18

19 years ago
docshell was only clearing the refresh timers when a url was redirected to the
browser window. So justloading a new url in the browser wasn't clearing the
timers. I just added code to force this to happen.

Travis, I hope you don't mind bug I'm going to take this bug from you so I can
check in my fix.
Assignee: travis → mscott
thanks for fixings this, mscott.  this bug has been messing me up for a while 
now.

(accepting for mscott)
Status: NEW → ASSIGNED

Comment 20

19 years ago
*** Bug 37630 has been marked as a duplicate of this bug. ***

Comment 21

19 years ago
*** Bug 37631 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 22

19 years ago
This bug was driving me batty so I took it from Travis and just checked in the fix.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 23

19 years ago
Setting to [dogfood-] radar.
Whiteboard: [dogfood+]

Comment 24

19 years ago
verified on Linux build 2000050208
Status: RESOLVED → VERIFIED

Comment 25

18 years ago
*** Bug 65805 has been marked as a duplicate of this bug. ***

Comment 26

18 years ago
Take a look at http://www.lifosa.com/~kaspar/framebug/frref.html
and you will wish to reopen this bug.
You need to log in before you can comment on or make changes to this bug.