Pressing Escape on Character Encoding warning box does not Cancel sending message

RESOLVED DUPLICATE of bug 340373

Status

Thunderbird
Message Compose Window
--
minor
RESOLVED DUPLICATE of bug 340373
12 years ago
12 years ago

People

(Reporter: Matt Carter, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8
Build Identifier: Mozilla Thunderbird version 1.5.0.8 (20061025)

When sending a message containing characters not in the current Character Encoding, a warning pop-up window appears entitled "Message Compose" saying "The message you composed contains characters not found in the selected Character Encoding." and giving three buttons: "Send in UTF-8", "Cancel", and "Send anyway".  Pressing the Escape key should be equivalent to clicking "Cancel".  Instead, pressing the Escape key sends the message.  This violates conventions on the Escape key.

Reproducible: Always

Steps to Reproduce:
1. Have outgoing mail character encoding set to "Western (ISO-8859-1)" (the default).
2. Compose a message containing non-ascii characters.
3. Click send.
4. The "characters not found in the selected Character Encoding" warning window appears.
5. Press the Escape key.

Actual Results:  
The message is sent.

Expected Results:  
The message should not be sent, so the user can return to the message composition window just as if s/he had clicked the "Cancel" button.

*** This bug has been marked as a duplicate of 340373 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.