context menu broken (crash on right-click)

VERIFIED DUPLICATE of bug 354624

Status

()

Firefox
General
--
blocker
VERIFIED DUPLICATE of bug 354624
11 years ago
11 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1) Gecko/20061010 Firefox/2.0

At http://www.exmatrikulationsamt.de/index.php?act=piXma&CODE=06&aid=206&pid=17906 (login required),
using the right-click above the the image causes the trunk to crash.

Reproducible: Always




TB27284515X
Created attachment 248552 [details]
very short testcase

testcase - image with link crashes trunk on rightclick. Sorry that I forgot the correct Build-ID: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061213 Minefield/3.0a1 - Build ID: 2006121304
Severity: normal → major
Component: General → General
Product: Firefox → Core
Version: unspecified → Trunk
QA Contact: general → general

Comment 2

11 years ago
can you please try it on the latest build? i can reproduce this.
 
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a1) Gecko/20061218 Minefield/3.0a1 ID:2006121811 [cairo]

It is still broken.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20061219 Minefield/3.0a2pre

Other ways to get a crash with right-click:

Go to http://talkback-public.mozilla.org/ and right-click in the Talkback-ID input ( TB27516645H ).

or

Go to bug 220900 and right click on the creator name.

Comment 4

11 years ago
those stacks are unfortunately not very usable, how about trying:

http://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg 
Created attachment 249166 [details]
Stack for the very small testcase
Created attachment 249167 [details]
Stack for right-click in input at talkback-public
Created attachment 249168 [details]
Stack for comment-id or creator links at bugzilla
I did some tests and it seems as the page context menu is completely broken, there's no difference if it's called by mouse or keyboard.
Severity: major → blocker
Component: General → General
Product: Core → Firefox
Summary: crash on right-click: ntdll.dll + 0x3426d (0x7c94426d) 4be23d70 → context menu broken (crash on right-click)
Sorry for the trouble.

Solution: Free Download Manager added its extension without asking to all profiles it could find and "infected" so the test profile. After removing it all worked fine.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Comment 10

11 years ago
sorry typo err.

i mean can't reproduce this.

but your talkback looks similar to mine on this bug# 354624


Updated

11 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 11

11 years ago

*** This bug has been marked as a duplicate of 354624 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE

Comment 12

11 years ago
thanks for following the steps. sorry for the imperfect experience.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.