Timezone-related test failures in AVM test-suite

VERIFIED DUPLICATE of bug 461758

Status

Tamarin
Virtual Machine
VERIFIED DUPLICATE of bug 461758
12 years ago
9 years ago

People

(Reporter: Issac Goldstand, Assigned: Dan Schaffer)

Tracking

Details

Attachments

(1 attachment, 4 obsolete attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Tests complete at 2006/12/14 11:07:12
Start Date: 2006/12/14 10:59:12
End Date  : 2006/12/14 11:07:12
Test Time : 8 minutes 0 seconds

passes    : 54736
failures  : 6

Results were written to f:/mozilla/js/tamarin/test/2006-12-14.2.html

FAILURES:
 
f:/mozilla/js/tamarin/test/as3/Definitions/Classes/MethodClosures/GetMCFromDyn
amicClass.abc : obj.getDate() = 1970 FAILED! expected: 1969
 f:/mozilla/js/tamarin/test/ecma3/Date/e15_9_5_29_1.abc : TDATE = new Date(9466
84800000);(TDATE).setUTCMinutes(1234567);TDATE.getHours() = 10 FAILED! expected:
11
 f:/mozilla/js/tamarin/test/ecma3/Date/e15_9_5_28_1.abc : TDATE = new Date(9466
84800000);(TDATE).setMinutes(1234567);TDATE.getTime() = 1020758820000 FAILED! ex
pected: 1020755220000
 f:/mozilla/js/tamarin/test/ecma3/Date/e15_9_5_28_1.abc : TDATE = new Date(9466
84800000);(TDATE).setMinutes(1234567);TDATE.valueOf() = 1020758820000 FAILED! ex
pected: 1020755220000
 f:/mozilla/js/tamarin/test/ecma3/Date/e15_9_5_28_1.abc : TDATE = new Date(9466
84800000);(TDATE).setMinutes(1234567);TDATE.getUTCHours() = 8 FAILED! expected:
7
 f:/mozilla/js/tamarin/test/ecma3/String/e15_5_4_6_2_rt.abc : var d = new Date(
0); d.indexOf = String.prototype.indexOf; d.getTimezoneOffset()>0 ? d.indexOf('3
1') : d.indexOf('01') = -1 FAILED! expected: 8 

Reproducible: Always
(Assignee)

Comment 1

12 years ago
Created attachment 249358 [details] [diff] [review]
patch for 3 test fixes

reproduced the 6 test failures on windows by setting timezone to +2:00 Jersualem.  I fixed 3 of the failures which seemed to be applicable to all + timezones.  we did not see these failures since generally only run tests on - timezones (EST and PST).  The other 3 failures are caused by the Date class not recognizing daylight savings perhaps.  The same problem exists on the standard javascript tests from which we copied the tamarin tests.  see $MOZ_SRC/js/tests/ecma/Date/15.9.5.28-1.js not sure if the failure is an actual vm problem.
Assignee: nobody → dschaffe
Status: UNCONFIRMED → ASSIGNED
Attachment #249358 - Flags: review?(cpeyer)
You guys are part of a larger community that includes the keepers of those "standard javascript tests" from which Tamarin's were forked.  Cc'ing some.

This reminds me to ask: can we unfork and consolidate tests?  The ES4 group in ECMA wants to build a shared testsuite, not as part of the new language spec, but in the open.  This is a big project, but it should be possible as a first step to unify tests that were duplicated, reconciling differences due to bugs not fixed in one side of the fork or the other (any other differences should be considered bugs or version-dependent tests).

/be

Comment 3

12 years ago
Created attachment 256484 [details] [diff] [review]
Changed the shell.as to reflect the current Daylight Savings time

Added functions to reflect current daylight savings time of US.
Attachment #256484 - Flags: review?(dschaffe)
(Assignee)

Comment 4

12 years ago
Comment on attachment 256484 [details] [diff] [review]
Changed the shell.as to reflect the current Daylight Savings time

marking obselete.  Subha will create another patch.
Attachment #256484 - Attachment is obsolete: true
Attachment #256484 - Flags: review?(dschaffe)

Comment 5

12 years ago
Created attachment 256684 [details] [diff] [review]
Added DST changes  in the shell.as and fixed 16 test case files 

Added the new  DST changes to the shell.as and fixed 15 files that called the old DST function and 1 test case file that had a bug on it
Attachment #256684 - Flags: review?(dschaffe)

Comment 6

12 years ago
Comment on attachment 256684 [details] [diff] [review]
Added DST changes  in the shell.as and fixed 16 test case files 

Because of the editor i was using the correct number of code changed was not reflected in the diff file.  Going to submit the patch again.
Attachment #256684 - Attachment is obsolete: true
Attachment #256684 - Flags: review?(dschaffe)

Comment 7

12 years ago
Created attachment 256831 [details] [diff] [review]
Added DST changes  in the shell.as and fixed 16 test case files
Attachment #256831 - Flags: review?(dschaffe)

Comment 8

12 years ago
Comment on attachment 256831 [details] [diff] [review]
Added DST changes  in the shell.as and fixed 16 test case files 

Making it obsolete, going to try one more time
Attachment #256831 - Attachment is obsolete: true
Attachment #256831 - Flags: review?(dschaffe)

Comment 9

12 years ago
Created attachment 256835 [details] [diff] [review]
Added DST changes in the shell.as and changed 16 more test files that were calling the DST function in the shell.as
Attachment #256835 - Flags: review?(dschaffe)
(Assignee)

Comment 10

11 years ago
Comment on attachment 249358 [details] [diff] [review]
patch for 3 test fixes

obseleting as the new DST changes contains these changes.
Attachment #249358 - Attachment is obsolete: true
Attachment #249358 - Flags: review?(cpeyer)

Updated

11 years ago
Assignee: dschaffe → nobody
Status: ASSIGNED → NEW
Component: Tamarin → Virtual Machine
Product: Core → Tamarin
QA Contact: tamarin → vm
Version: Trunk → unspecified

Updated

11 years ago
Status: NEW → ASSIGNED

Comment 11

11 years ago
Transferred Bug from Core->Tamarin to Tamarin
Assignee: nobody → dschaffe
Status: ASSIGNED → NEW

Updated

11 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 12

10 years ago
Comment on attachment 256835 [details] [diff] [review]
Added DST changes in the shell.as and changed 16 more test files that were calling the DST function in the shell.as

cleaning up old reviews.  marking obselete.  I believe we fixed the timezone problems in other patches.
Attachment #256835 - Flags: review?(dschaffe)
Attachment #256835 - Flags: review-

Updated

10 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 461758

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.