If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Go-> Next-> 'Unread Message' jumps to allready read messages (once)

RESOLVED FIXED

Status

MailNews Core
Backend
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: Ruediger Lahl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061215 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061215 SeaMonkey/1.5a

---------
This is a little bit difficult for me, because its hard to explain that bug with my broken English.
The German description of this bug is here: <elshn0.2h0.1@privat.lahls.de>
---------

The shortcut 'n' should jump to the next unread message, but it jump to the last already read message of the next newsgroup in folder pane.

Reproducible: Always

Steps to Reproduce:
1. find a complete as read marked newsgroup in folder pane.
2. go to the next group under that group in your folder pane with unread 
   messages.
3. read all messages in this group and go back to the first group.
4. use 'n' to jump to the next unread message.

Actual Results:  
'n' jump again in the second group to the last read message.

Expected Results:  
'n' should jump to the next group with unread messages.

This bug can be execute through the whole folder pane, if you read all messages in all groups and click on first group in top of the folder pane. 'n' jumps from group to group and shows you the last read message in each group. This bug disappears after the first 'run'.

I think, this is a regression of the patch for https://bugzilla.mozilla.org/show_bug.cgi?id=298737

For me this patch seams to have two more side effects, but I found nobody who could reproduce them.

1. after reading the last unread message, fold the groups by clicking on the servername. After that unfold the groups again. SeaMonkey shows shortly in all groups unread messages that was read before.

This short(400KB) avi shows the effect:http://lahls.de/public/sm_phantom_msg.avi

2. the same happens, when SeaMonkey load new messages from the server, and in that case its really looks like, as SeaMonkey set new messages as read!
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk

Comment 1

11 years ago
Which build of TB are you using when you see this?
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> Which build of TB are you using when you see this?

I see this with the actual SeaMonkey-Trunk on WinXP and another user on Linux.
(See the UA in the description)

Comment 3

11 years ago
Confirmed on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2pre) Gecko/20061219 Thunderbird/2.0b1 ID:2006121903.

Assignee: mail → nobody
Status: UNCONFIRMED → NEW
Component: MailNews: Main Mail Window → MailNews: Backend
Ever confirmed: true
Product: Mozilla Application Suite → Core
QA Contact: backend
Summary: Go-> Next-> 'Unread Message' jumps to allready read messages → Go-> Next-> 'Unread Message' jumps to allready read messages (once)

Comment 4

11 years ago
*** Bug 364416 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

11 years ago
(In reply to comment #0)

> The shortcut 'n' should jump to the next unread message, but it jump to the
> last already read message of the next newsgroup in folder pane.

Fixed with a new patch for https://bugzilla.mozilla.org/show_bug.cgi?id=298737
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Depends on: 298737
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.