GTK is hogging all shared memory

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
19 years ago
14 years ago

People

(Reporter: jbanes, Assigned: leaf)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I am using Solaris 8 on an Ultra 5 machine w/128 MB of RAM. Originally when I
tried to run Mozilla, I would get two GTK errors on startup and mozilla would
die (since M14). Later on I found the problem was that GTK is a shared memory
hog and that the shared memory needs to be adjusted. The fix is at:

http://www.scms.rgu.ac.uk/staff/jr/computing/unix/xmms/#problems

I set it to the maximum amount of shared memory allowed by Solaris (8 megs).
This allowed me to run Mozilla. However, after a couple of runs the shared
memory runs out and I have to log out and log back in to run Mozilla. With the
most recent nightly (2000-4-18), Mozilla is finally stable and does not core
dump after several minutes. As a result, I quickly found that Mozilla can and
will interfere with other apps that are using shared memory. My specific
instance is the SunPCi card which makes use of 1 meg of shared memory. 

The problem I ran into is that my Windows session would lock when accessing a
network drive mapped to the Solaris directory structure. The resulting message I
received on the console is:

sunpcidrv:   enqueue_kmem_request() kmem_alloc(data) failed on size 0

When I closed Mozilla, the problems disappeared. It is my contention that
Mozilla is using all available shared memory and is thus disrupting other
programs. My version of GTK+ is 1.1.2 and came preinstalled on my system. 

Is there some way to limit the shared memory usage of GTK+ to say 1 meg or
perhaps even 1/8 of the available shared memory? This I think would go a long
way to solving these problems. Thank you.

Comment 1

19 years ago
changing from architecture to browser
Assignee: endico → cls
Component: GFX → Build Config
Product: Architecture → Browser
QA Contact: nobody → granrose
Version: 5.0 → other

Comment 2

19 years ago
I think this is a known problem.  What sort of performance penalty are we
looking at by compiling mozilla against a gtk that was compiled with
--enable-shm=no ?
Status: NEW → ASSIGNED

Comment 3

19 years ago
interesting.  I don't really know.  I have enable-x11-shm turned off in mozilla
(even if you enable it) so we don't use it.  gdkrgb creates some shared regions
when gdk_init gets called, but other than that I don't know.  I will try and
contact raph and see what he says.
(Reporter)

Comment 4

19 years ago
To add, here are the error messages I get on startup:

Gdk-ERROR **: BadAlloc (insufficient resources for operation)
  serial 214 error_code 11 request_code 45 minor_code 0
Gdk-ERROR **: BadFont (invalid Font parameter)
  serial 215 error_code 7 request_code 47 minor_code 0

Updated

19 years ago
Target Milestone: --- → M20
Should this be "future" or are you actually targetting M20?

Comment 6

19 years ago
I'm hoping that between now and M20, I'll actually have time to build a gtk with
--enable-xshm=no on solaris to test this.

Comment 7

18 years ago
Turns out that I don't have the time. :(
Target Milestone: M20 → Future
Is this bug report still valid ? It dates back to M14 and there is no activity.
Shuld n't it be closed ?

Comment 9

16 years ago
Mass reassign to default build config owner
Assignee: cls → mozbugs-build
Status: ASSIGNED → NEW
Priority: P3 → --
Mass reassign of Build/Config bugs to Leaf.
Assignee: mozbugs-build → leaf
Target Milestone: Future → ---
(Reporter)

Comment 11

15 years ago
This bug is over 3 years old and (as far as I can tell) is no longer exhibited by current builds on 
Solaris 8. As far as I'm concerned, it can probably be closed.
Marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.