Local anchors within a scrolling div do not work

VERIFIED DUPLICATE of bug 8927

Status

()

P3
normal
VERIFIED DUPLICATE of bug 8927
19 years ago
19 years ago

People

(Reporter: rsalesas, Assigned: troy)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
The following example shows a scrolling div with an anchor at the top and one 
at the bottom (so only one is visible). The links select the anchors, and in 
Internet Explorer properly scroll the div to the top or the bottom. Mozilla 
ignores the link.


<html>
<head>
	<title>Untitled</title>
</head>

<body>
<div style="overflow:auto;height:200px">
<div>
<a name="top">TOP</a>
<table cellspacing="2" cellpadding="2" border="1" height=2000>
<tr>
    <td>xxx</td>
</tr>
</table>
<a name="bottom">BOTTOM</a>
<a href="#top">go to top</a>
</div>
</div>
<a href="#top">top</a>
<a href="#bottom">bottom</a>
</body>
</html>

Comment 1

19 years ago
is this the same as bug 8927?  

updating component and owner.
Assignee: asadotzler → troy
Component: Browser-General → Layout
QA Contact: jelwell → petersen
Agreed.  Marking duplicate

*** This bug has been marked as a duplicate of 8927 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 3

19 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.