nsEffectiveTLDService::getEffectiveTLDLength returns 2 for .co.uk domains

VERIFIED FIXED

Status

()

Core
Networking
--
major
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: dao, Assigned: dveditz)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061217 Minefield/3.0a1
Build Identifier: 

Well, speaks for itself.

Reproducible: Always

Steps to Reproduce:
tldService.getEffectiveTLDLength("theregister.co.uk")
Actual Results:  
2

Expected Results:  
5
(Reporter)

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

11 years ago
That's because there's no data-file yet, see bug 342314.
(Reporter)

Updated

11 years ago
Depends on: 342314
(Reporter)

Updated

11 years ago
Blocks: 366797
(Reporter)

Updated

11 years ago
No longer blocks: 366797
(Assignee)

Updated

11 years ago
Assignee: nobody → dveditz
(Assignee)

Comment 2

11 years ago
Bug 342314 fixed, which is expected to fix this issue.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.