Style inheritance problem in tables

VERIFIED DUPLICATE of bug 31955

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED DUPLICATE of bug 31955
18 years ago
18 years ago

People

(Reporter: rsalesas, Assigned: Pierre Saslawsky)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
The following code shows that the text in the cell takes the right font size, 
but not the right color. In fact, it ignores the color.

<style>
	.p {color:green;font-size:8px}
	.listChoiceBar .p {color:red;font-size:38px}
</style>

<TABLE BORDER=0 cellspacing=0 cellpadding=0 class="listChoiceBar">
	<TR class="p">								
		
	<td>View</TD>
	</tr>
</table>

Comment 1

18 years ago
I'm attaching a testcase based on the reporter's.  Three tables, each in a div
of class "gr".  Anything of class "rd" inside that div should be red, and 30px. 
Making the TABLE class="rd" has no effect at all, except that the style of the
DIV isn't inherited. Making the TR class="rd" applies the font size, but not the
color.  Only making the TD class="rd" has the expected effect.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Summary: Style in cell ignores color but uses font size → Style inheritance problem in tables

Comment 2

18 years ago
Created attachment 7764 [details]
testcase

Comment 3

18 years ago
This is a NavQuirks issue: In standard mode it works correctly, however since 
there is no DocType in the testcase NavQuirks kick in and the rule there is to 
block inheritance into tables. Marking as a dup of 31955 since that bug deals 
with the table inherticance quirk.

*** This bug has been marked as a duplicate of 31955 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.