Assertion when creating a new message

VERIFIED FIXED in M16

Status

P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: scottputterman, Assigned: bugzilla)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Every time I do New Msg from the 3 pane I get this assertion:

  NS_ASSERTION((inChild && outParent && outOffset), "bad args");

NTDLL! 77f7629c()
nsDebug::Assertion(const char * 0x03507768, const char * 0x03507744, const char
* 0x0350770c, int 204) line 191 + 13 bytes
GetNodeLocation(nsIDOMNode * 0x00000000, nsCOMPtr<nsIDOMNode> * 0x0012eb3c, int
* 0x0012eb40) line 204 + 44 bytes
nsMsgCompose::ConvertAndLoadComposeWindow(nsIEditorShell * 0x05b01b30, nsString
& {""}, nsString & {""}, nsString & {""}, int 0, int 1) line 308 + 22 bytes
nsMsgCompose::BuildBodyMessageAndSignature() line 2107 + 54 bytes
nsMsgDocumentStateListener::NotifyDocumentCreated(nsMsgDocumentStateListener *
const 0x05b0e660) line 1779
nsEditor::NotifyDocumentListeners(nsEditor * const 0x05c07d90, nsEditor::
TDocumentListenerNotification eDocumentCreated) line 2708 + 23 bytes
nsEditor::PostCreate(nsEditor * const 0x05c07d90) line 897
nsHTMLEditor::PostCreate(nsHTMLEditor * const 0x05c07d90) line 527 + 9 bytes
nsEditorShell::PrepareDocumentForEditing(nsIDocumentLoader * 0x05aac9e0, nsIURI
* 0x05b0e450) line 423 + 32 bytes
nsEditorShell::OnEndDocumentLoad(nsEditorShell * const 0x05b01b38,
nsIDocumentLoader * 0x05aac9e0, nsIChannel * 0x05b0e1b0, unsigned int 0) line
4258 + 27 bytes
nsWebShell::OnEndDocumentLoad(nsWebShell * const 0x05aab590, nsIDocumentLoader *
0x05aac9e0, nsIChannel * 0x05b0e1b0, unsigned int 0) line 1579
nsDocLoaderImpl::FireOnEndDocumentLoad(nsDocLoaderImpl * 0x05aac9e0, nsIChannel
* 0x05b0e1b0, unsigned int 0) line 638
nsDocLoaderImpl::DocLoaderIsEmpty(unsigned int 0) line 514
nsDocLoaderImpl::OnStopRequest(nsDocLoaderImpl * const 0x05aac9e4, nsIChannel *
0x05b0e1b0, nsISupports * 0x00000000, unsigned int 0, const unsigned short *
0x00000000) line 458
nsLoadGroup::RemoveChannel(nsLoadGroup * const 0x05aac980, nsIChannel *
0x05b0e1b0, nsISupports * 0x00000000, unsigned int 0, const unsigned short *
0x00000000) line 544 + 39 bytes
nsStreamIOChannel::OnStopRequest(nsStreamIOChannel * const 0x05b0e1b4,
nsIChannel * 0x05b0fef0, nsISupports * 0x00000000, unsigned int 0, const
unsigned short * 0x00000000) line 627
nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 0x05b0fb70) line 307
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x05b0f990) line 97 + 12 bytes
PL_HandleEvent(PLEvent * 0x05b0f990) line 575 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x015922e0) line 520 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x003e0ea8, unsigned int 49415, unsigned int 0,
long 22618848) line 1030 + 9 bytes
USER32! 77e71820()
01
(Assignee)

Comment 1

19 years ago
reassign to editor team for investigation
Assignee: ducarroz → beppe

Comment 2

19 years ago
assigning to kin for review
Assignee: beppe → kin
Target Milestone: --- → M17
(Assignee)

Comment 3

19 years ago
chat with kin:

Kin Blas:	Hi
Kin Blas:	http://bugzilla.mozilla.org/show_bug.cgi?id=36425
Kin Blas:	is a bug in MessageCompose not editor.
Kin Blas:	nodeInserted
Kin Blas:	never gets created if aQuoted is false
Kin Blas:	and the code below it doesn't check to see if it's false before it tries toinsert it.
Assignee: kin → ducarroz
(Assignee)

Comment 4

19 years ago
I have a fix for it.
Status: NEW → ASSIGNED
Whiteboard: Fix in hand
Target Milestone: M17 → M16
(Assignee)

Comment 5

19 years ago
*** Bug 36839 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

19 years ago
Fixed and checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Whiteboard: Fix in hand

Comment 7

19 years ago
Linux (2000-05-22-08 M16)
Mac (2000-05-22-08 M16)
Win32 (2000-05-22-09 M16)
This problem has been fixed.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.