crash upon clicking Internet Search in preferences tree

VERIFIED WORKSFORME

Status

P3
critical
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: bugzilla, Assigned: matt)

Tracking

({crash, regression})

Trunk
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Sorry, this is likely a dup but I couldn't find it.
Build ID: 2000041908

Reproducability: Always

Steps to reproduce:
(1) Open preferences from Edit menu
(2) Click "Internet Search" in the tree at the left

Expected Results: normal Internet Search options appear so enduser can change 
them

Actual Results: Internet Search options appear, however Moz then GPF's.

Details of GPF are as follows:

MOZILLA caused an invalid page fault in
module GKHTML.DLL at 0167:01b8ada5.
Registers:
EAX=00000000 CS=0167 EIP=01b8ada5 EFLGS=00010206
EBX=00000000 SS=016f ESP=0068d474 EBP=0068db1c
ECX=0000000f DS=016f ESI=00000000 FS=2c0f
EDX=40000024 ES=016f EDI=01e862d0 GS=0000
Bytes at CS:EIP:
80 7c 08 ff 0a 75 78 ff 4d fc eb 73 8d 45 fc 8d 
Stack dump:
00000000 01e862d0 00000000 00000000 00000000 00000000 0270a020 00000000 
0068d49c 00000100 00000002 00000c8f 02680dc4 00000270 00000190 0068d4e0 

Again, sorry for dup
davidhj@mail.com added a comment to this effect in bug 33361 (which addresses
another issue, methinks).
was able to repro this on today's opt comm m16 bits on winNT and linux.
strangely, could not reproduce on the Mac.
Keywords: crash, regression
Hardware: PC → Other

Comment 3

19 years ago
My bug was that selecting any search engine but Netscape would crash Moz. Thuis

seems to be that just Edit Preferences ---> Search crashes Moz.

(Reporter)

Updated

19 years ago
Blocks: 33361
*** Bug 36644 has been marked as a duplicate of this bug. ***
*** Bug 36947 has been marked as a duplicate of this bug. ***
OS: Windows 98 → All
Hardware: Other → All
no longer a problem, using today's opt comm bits on linux and winNT (still
waiting for mac build), 2000.04.25.09. marking wfm. but pls reopen if you still
see this w/a recent build.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

19 years ago
verif. wfm with 2000042508 win98
Status: RESOLVED → VERIFIED
yep, looks fine using the opt moz bits on Mac, 2000.04.25.08.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.