Thunderbird generates names to attached files with Unicode names that other e-mail (and webmail) applications cannot understand.

RESOLVED DUPLICATE of bug 309566

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 309566
12 years ago
12 years ago

People

(Reporter: utf16, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060802 Mandriva/1.5.0.7-1mdv2007.0 (2007.0) Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060802 Mandriva/1.5.0.7-1mdv2007.0 (2007.0) Firefox/1.5.0.7

Unicode characters in an attachment are possible only if the message receiver is a Linux Thunderbird user.

Reproducible: Always

Steps to Reproduce:
1. Make sure your system locale is "UTF-8".
2. Download the file from the link.
3. Send it to yourself via Thunderbird using "UTF-8" encoding.
4. Use another application or a webmail interface to reveive the message.

Actual Results:  
The results depend on e-mail or webmail program you use. "Outlook" receives the file as "ATT00007.doc". Kmail will open it as "%82%D1%80%D0%B0%D0%BD%D1%81%D0%BF%D0%BE%D1%80%D1%82%2E%64%6F%63". Most webmail clients show this file as "unnamed".

Expected Results:  
The file should appear in any application or interface as "Извещ № 81-транспорт.doc" with the possibility to save it with a correct filename.

In Mandriva Thunderbird itself is compatible with the filenames it generates. Though it is possible that in other distributions files with Unicode names sent with Thunderbird return as garbage-Unicode (KMail behaviour) to Thunderbird itself.

Comment 1

12 years ago
Only if they don't support RFC2231.

*** This bug has been marked as a duplicate of 309566 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.