[rfe] add EULA support in the XPI/installer

RESOLVED DUPLICATE of bug 275743

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 275743
12 years ago
12 years ago

People

(Reporter: moco, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

[rfe] add EULA support in the XPI/installer

this problem comes from patrick hunt, the primary author of the del.icio.us
extension from yahoo! (https://addons.mozilla.org/firefox/3615/)

below are selected quotes from an email thread about this.  putting it into bugzilla so that others (primarily mark finkle and robert strong) have some context.

patrick writes:

"is there a way to add EULA support in the XPI/installer? Basically show the eula and accept/decline buttons (whatever) during the installer dialog. Also eula support on AMO itself."

about adding eula support to amo, basil and shaver wrote (a few weeks ago) that they think EULA presentation is under consideration for the next AMO revision.

about client side eula, patrick writes:

"I was thinking that we should package the EULA in the XPI itself. During the "install dialog" if the xpi contains a EULA the dialog could do the right thing - probably means display accept/decline buttons along with the eula text (this would have to be worked out in detail if you have interest).

Nice thing about this is if you don't have a eula then the dialog is unchanged, if you do have a eula then the right thing can happen, even if the user gets the xpi from a location other than AMO (having on AMO would be great too though). "

basil writes:

"I just tried out an extension that does something similar - AllPeers. If I recall, it presented the EULA after install."

patrick writes:

"Tave to present the eula _before_ the extension is actually installed (ie running). Since our extension code doesn't start running until the extension is installed and the browser restarted it's not sufficient for them to do this (I tried). That's why I suggested adding something to the install dialog itself with the content (EULA) contained within the XPI."

shaver writes:

"Another issue to consider -- because I know you were dying for more! -- is whether every user on the system needs to agree, or every new profile, etc.  It's an edge case for you right now, but if an extension is installed globally it's available for all users on the system, and I could see that being the case as part of some custom distribution or other software-bundling thing down the road."
For those keeping track at home, AMO's bug is bug 342973, and this bug is bug 275743

*** This bug has been marked as a duplicate of 275743 ***

*** This bug has been marked as a duplicate of 275743 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.