cookie properties should not be editable

VERIFIED DUPLICATE of bug 36942

Status

()

Core
Networking: Cookies
P1
normal
VERIFIED DUPLICATE of bug 36942
18 years ago
18 years ago

People

(Reporter: buster, Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
1. open mozilla
2. view stored cookies
3. The dialog that appears is a list of cookies followed by 6 cookie properties, 
each of the form:

---------     ---------------
| label |    | text control |
---------    ----------------

The text controls are all editable.  Click in one and start typing, and sure 
enough, text gets added.

These should either be read-only, or even better they should just be text.  
Simple text in a div with a white background would give the same visual effect.  
I assume it is not important to support copy of this information from these 
fields, since there's no "Edit" menu.  If it is, you could leave them as read 
only text fields, but note that text fields are a lot more expensive than simple 
HTML text content.
(Reporter)

Comment 1

18 years ago
marked P1 M16 to get immediate attention, because related bug 25154 is marked 
"nsbeta2."  Feel free to set your own priority after you've looked at this.

If you decide to go with simple text rather than text controls, 25154 goes away 
completely.  Otherwise, I'll spend some time looking into the rendering issues 
raised in 25154 before beta2.
Blocks: 25154
Priority: P3 → P1
Target Milestone: --- → M16
(Assignee)

Comment 2

18 years ago
We (Ben, that is) chose text controls because we needed to be able to scroll 
this field.  But I recall that he did make it read-only at the time he 
implemented it.  So I'm surprised that it is now write-able.  I'll look into it.
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
No longer blocks: 25154
Why shouldn't this be editable?

If you make them non-editable in the _Mozilla_ tree, please have it controlled
by a pref.  People have been asking for better control over their cookies for a
long time.
(Assignee)

Comment 4

18 years ago
Just changing the attribute from non-editable to editable does not mean you can 
change the value of a cookie.  You'll be able to change the display on the 
screen but the actual cookie value will not change.

Editing cookie values was never part of the cookie-viewer design and no code has 
ever been implemented to do it.  This bug report is not requesting that they be 
editable, rather it is saying that they appear to be editable on the screen and 
of course that is incorrect.
Oh, OK.  I'll file an RFE for actually doing the editing, maybe send a patch in
if I get some time.

I agree that the widget shouldn't be editable if the it won't have any effect.
I set a readonly="true" attribute on the fields, which I'm told should do the 
trick. There was a period of time when these were not editable. Could this be a 
text widget regression? 
(Assignee)

Comment 7

18 years ago
I just took a look at it and the field is not editable.  I can not insert new 
characters into arbitrary positions of the text, nor can I delete any 
characters.  So all this is working correctly so far since the field has the 
read-only attribute.

But if I double-click on the text field, it hilites and then anything that I 
type appears appended to the beginning of the text.  I'll assume that this is 
what buster was observing when he filed this report.

So I opened a new report on this incorrect behavior of read-only text fields 
(bug 36942) and am marking this bug as a dup of that one.

*** This bug has been marked as a duplicate of 36942 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 8

18 years ago
dupe of bug 36942 which Steve opened
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.