source code checkout example shows wrong command

RESOLVED FIXED

Status

Developer Documentation
General
RESOLVED FIXED
12 years ago
5 years ago

People

(Reporter: Ray Kiddy, Assigned: Dawn Endico)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/418.9.1 (KHTML, like Gecko) Safari/419.3
Build Identifier: 


Two things are wrong. The page shows the example:

<code>
cvs -d :pserver:anonymous:anonymous@cvs-mirror.mozilla.org:/cvsroot co mozilla/client.mk
cd mozilla
make -f client.mk checkout MOZ_CO_PROJECT=browser
</code>

First, one must login and this is not shown.

Second, the url for the repository is wrong.

The "anonymous" should only appear once. This should be:

<code>
cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot co mozilla/client.mk
cd mozilla
make -f client.mk checkout MOZ_CO_PROJECT=browser
</code>


Reproducible: Always
(Reporter)

Comment 1

12 years ago
Ok, I realized something. This is a wiki. I can make the edit myself. Duh! :-)

Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 2

12 years ago
FWIW, the wiki was not wrong: anonymous:anonymous was a username:password, which is supposed to work in CVSROOT. It happens to not work in MSYS make, which sucks. But since our anonymous CVS server doesn't actually use the password, it doesn't really matter.
*** This bug has been confirmed by popular vote. ***
Component: Mozilla Developer → Documentation Requests
Ever confirmed: true
Product: Documentation → Mozilla Developer Center
Component: Documentation Requests → Documentation
Product: Mozilla Developer Network → Mozilla Developer Network
Component: Documentation → General
Product: Mozilla Developer Network → Developer Documentation
You need to log in before you can comment on or make changes to this bug.