Password autofill after a username is selected from field dropdown only fills password when page has loaded

RESOLVED WORKSFORME

Status

()

Toolkit
Password Manager
--
minor
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: andrew.weiser, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/02, URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 (CK-IBM) Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 (CK-IBM) Firefox/2.0

I have two remembered usernames at www.swiftcd.com, which is slow to load (third party resources load slowly until the page is fully loaded).  As soon as the logon page (https://www.swiftcd.com/login.asp) starts loading, I can double-click in the username field and select one of the two usernames from the dropdown suggestion field and have the username filled in while the page is still loading.  However, the password field remains blank until the page has finished loading, at which time the password is filled in.  This delays logging on with the remembered password until the page is fully loaded.  This is a variant of the fixed bug 221634 (password manager needs to fill in forms before the page finishes loading).  This fix has worked for me when there is a single username to autofill, but has not stopped the symptoms I have reported.

Reproducible: Always

Steps to Reproduce:
1. Create two accounts at www.swiftcd.com and have the password manager remember the passwords for both.
2. Try to logon at https://www.swiftcd.com/login.asp
3. Select one of the usernames from the userID auto-suggest field.
4. Wait for the password to be auto-filled.

Actual Results:  
Password field is autofilled only when the page has stopped loading.

Expected Results:  
Password field should be autofilled as soon as a username is selected.
I cannot reproduce this bug on Firefox 2.0.0.4.  Reporter, please update to 2.0.0.4 and try again.  If you are still experiencing issues, please try with a new profile or safe mode.  Just post a comment here if you need help with any of that.

If you do not reply in one week, this bug will be resolved WORKSFORME.
Whiteboard: CLOSEME 07/02
The one week deadline for reporter comments has passed.  Please open a new bug if you are still having this issue.  This bug is being resolved WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.