Bookmarks are broken!!

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Steve, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: Firefox 2.0.0.1

After upgrading to 2.0.0.1 my bookmarks are not working properly.
When I first start Firefox and go to my bookmarks I and see them all and choose anyone I want. If I then click on Bookmarks again NOTHING HAPPENS, Bookmarks will NOT open. If I close Firefox and re-open it all is fine for ONLY ONE BOOKMARK CHOICE, then again, if I click on Bookmarks it will NOT open. Close Firefox and re-open it and I can again choose only one. This is the first BAD build I've experienced with FireFox.

Reproducible: Always

Steps to Reproduce:
1.Open Firefox
2.Open Bookmarks and choose a URL
3.Bookmarks will not open again during the current session and must be closed and re-opened in order to access Bookmaks again.

Actual Results:  
Start Firefox, go to bookmarks and choose a URL then try to open bookmarks again and it will not open.

Expected Results:  
NOTHING.. NO bookmarks until I close and reopen Firefox

about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-official-branding --enable-optimize --disable-debug --disable-tests --enable-static --disable-shared --enable-svg --enable-canvas --enable-update-packaging
maybe some kind of http://kb.mozillazine.org/Bookmarks_not_saved#Corrupt_localstore.rdf_file ?

Comment 2

11 years ago
Confirmed. In addition, not only the bookmarks won't expand - after the first bookmark you open other menus won't work properly also. Error occured first after todays update to 2.0.0.1 and never occured on previous versions.

So, basically the bookmarks are there and not lost, but the menu won't work the intended way.

Comment 3

11 years ago
I had the same problem after installing 2.0.0.1 from 1.5.0.7
I also found that other menu drop-downs had similar problems.

I was prompted to upgrade by Firefox, and closed the running version of Firefox when prompted by the installer application. (I think this is the key.)

I suspect the problem and the solution is similar to Bug 357922.
https://bugzilla.mozilla.org/show_bug.cgi?id=357922

MY SOLUTION:

Closed Firefox manually.
Reinstalled Firefox 2.0.0.1 without uninstalling.

So far, I haven't had the problem.

Comment 4

11 years ago
Actually, I'm having problems again.
Did a clean installation of 2.0.0.1 and the problem is reproducible on my laptop.
Installing Firefox 2.0 does not have the problem.

Comment 5

11 years ago
Is this a dup of Bug 364424?
Chances are, it is.

Are you both using iFox as your theme (or, another non-default theme)? If you start Firefox in safe mode (http://kb.mozillazine.org/Safe_mode) does the problem go away?

Comment 7

11 years ago
(In reply to comment #6)
> Chances are, it is.
> 
> Are you both using iFox as your theme (or, another non-default theme)? If you
> start Firefox in safe mode (http://kb.mozillazine.org/Safe_mode) does the
> problem go away?
> 

I was having the same problem.  I uninstalled iFox, and the problem went away.

Thank you!
Ray Debs
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Thanks for your report - you may have better success pursuing one of the support options at http://www.mozilla.org/support/ or trying the diagnostic steps at http://kb.mozillazine.org/Standard_diagnostic_(Firefox)

If you still wish to pursue this report, we need enough detail that we can see the same problem happen on our systems - see the bug writing guidelines at http://developer.mozilla.org/en/docs/Bug_writing_guidelines - if you add details to this report, please reopen it and we'll take another look.
You need to log in before you can comment on or make changes to this bug.