Height of <select> doesn't change, when "style.height" increases 6px by Script.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Bockly, Unassigned)

Tracking

({testcase})

2.0 Branch
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/14)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.8.1) Gecko/20061010 Firefox/2.0

HTML.
<select id="slct" style="font-size:11px; height:16px; width:100px;"><option>12345</option></select>

By JavaScript.
document.getElementById("slct").style.height = "22px";

But the height doesn't change.

Reproducible: Always

Steps to Reproduce:
1.HTML
  <select id="slct" style="font-size:11px; height:16px; width:100px;">
    <option>12345</option>
  </select>

2.JavaScript
  var slctstyle = document.getElementById("slct").style;
  // simple check
  slctstyle.height = "22px";
  // operations check
  with(slctstyle){
    height = 6 + parseFloat(height) + "px";
  }

3.As well as 6 pixels, the problem doesn't occur.


Actual Results:  
Height doesn't change.

It is possible to confirm in the following:
1.You confirm operation actually.
2.by DOM Inspector.
  SELECT - CSS Style Rules - style - height: "22px"
  but
  Javascript Object - offsetHeight: "18"
  


Expected Results:  
When "style.height" increases 6px, the problem doesn't occur.
(Reporter)

Comment 1

11 years ago
Created attachment 249602 [details]
Sample of height doesn't change.
(Reporter)

Comment 2

11 years ago
Created attachment 249604 [details]
Sample of height doesn't change.
Attachment #249602 - Attachment is obsolete: true
(Reporter)

Comment 3

11 years ago
Target:
Firefox 1.5
Firefox 2
SeaMonkey 1.5 Alpha

The following browser works right.
Firefox 3.0 Alpha1
Reporter, are you saying this doesn't work on Fx 1.5 / Fx 2.0 / SM 1.5 but it does on trunk?
Keywords: testcase
Whiteboard: CLOSEME 07/14
Version: unspecified → 2.0 Branch
(Reporter)

Comment 5

11 years ago
Yes.
Not work in Fx 1.5.0.12 and Fx 2.0.0.4.
Work in Fx 3.0 a1.

I want to work in Fx1.5 and Fx 2.0.
But is it better that I change the status of FIXED?
The Firefox 1.5 branch is now no longer supported. The only bugs being landed for the 2.0 branch are security, stability and regression bugs. Since this bug is none of these, and it is fixed on the trunk (For Fx 3) this bug is WORKSFORME. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.