libnss3.so with NSS_3.11.1 and NSS_3.10 not found (required by ./firefox-bin)

RESOLVED WORKSFORME

Status

()

Firefox
Shell Integration
--
critical
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Timofei B. Bolshakov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.13) Gecko/20060501 Fedora/1.7.13-1.1.fc4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.13) Gecko/20060501 Fedora/1.7.13-1.1.fc4

It does not start at all. That happends after firefox 2 updated itself automatically.

I am running Fedora 4 and I have no idea where to take correct nss3 - I tryied couple I found on the web, but it does not work.

Reproducible: Always

Steps to Reproduce:
1. Unzip Firefox 2.0.0.1 on Fedora 4
2. Try to start firefox-bin form shell

Actual Results:  
It will print the error message about libnss3.so and die

Expected Results:  
running Firefox 2.0

Died
You need to start firefox from the "firefox" script that should be found in the same directory as firefox-bin, since this script sets up enviroment variables that tell firefox where to find certian libraries.

Comment 2

11 years ago
WFM with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/0000000000 Firefox/2.0.0.4 (Ubuntu-edgy) using the "firefox" script (also mentioned in comment #1).

Reporter, can you verify whether you still see the problem when running "firefox" instead of "firefox-bin"?
(Reporter)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Changing resolution to WORKSFORME since FIXED is reserved for bugs that have known code changes to fix them.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.