Double warning and errors for remote calendar on http://sd-calendar.staroffice.de/

VERIFIED FIXED

Status

VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: omarb.public, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

When I subscribed to calendar on http://sd-calendar.staroffice.de/ I saw two the same warning. I noticed different behaviour depended on what I selected

Reproducible: Always

Steps to Reproduce:
1.Subscribe to remote calendar on http://sd-calendar.staroffice.de/
2.Restart Thunderbird
3.You can see the same two warnings "insecure login on sd-calendar.staroffice.de!" (do not select 'don't ask again')

Scenario 1:
1.Select ok and again ok
Result- everything is fine
Scenario 2:
2.Select cancel and again cancel
3.Open console and see errors:
Error: error: [Exception... "Login failed. Invalid session ID."  nsresult: "0x804a0201 (<unknown>)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapSession.js :: anonymous :: line 372"  data: no]
Source File: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapSession.js
Line: 137
Error: error: [Exception... "Login failed. Invalid session ID."  nsresult: "0x804a0201 (<unknown>)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapSession.js :: anonymous :: line 372"  data: no]
Source File: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapSession.js
Line: 137
Error: error: [Exception... "Login failed. Invalid session ID."  nsresult: "0x804a0201 (<unknown>)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapSession.js :: anonymous :: line 372"  data: no]
Source File: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapSession.js
Line: 137
Error: error: getItems() ignored: [Exception... "Login failed. Invalid session ID."  nsresult: "0x804a0201 (<unknown>)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapSession.js :: anonymous :: line 372"  data: no]
Source File: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapCalendar.js
Line: 157
Error: Failed to fetch todo items: 0x80004005
Source File: chrome://lightning/content/calendar-todo-list.xml
Line: 130
Error: error: getItems() ignored: [Exception... "Login failed. Invalid session ID."  nsresult: "0x804a0201 (<unknown>)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapSession.js :: anonymous :: line 270"  data: no]
Source File: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapCalendar.js
Line: 157
Error: Failed to fetch todo items: 0x80004005
Source File: chrome://lightning/content/calendar-todo-list.xml
Line: 130
Error: error: getItems() ignored: [Exception... "Login failed. Invalid session ID."  nsresult: "0x804a0201 (<unknown>)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapSession.js :: anonymous :: line 270"  data: no]
Source File: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapCalendar.js
Line: 157
Error: error: getItems() ignored: [Exception... "Login failed. Invalid session ID."  nsresult: "0x804a0201 (<unknown>)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapSession.js :: anonymous :: line 270"  data: no]
Source File: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapCalendar.js
Line: 157

Scenario 3:
1.Select ok and then cancel
2. Go to Calendar Tab below mini calendar
3.Right click on the remote calendar and select properties
Result:
1.Unusable edit calendar window opens and it's impossible to resize it
2.Errors:
Error: [Exception... "Login failed. Invalid session ID."  nsresult: "0x804a0201 (<unknown>)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapSession.js :: anonymous :: line 270"  data: no]
Source File: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapSession.js
Line: 270
Error: error: getItems() ignored: [Exception... "Login failed. Invalid session ID."  nsresult: "0x804a0201 (<unknown>)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapSession.js :: anonymous :: line 270"  data: no]
Source File: file:///C:/Documents%20and%20Settings/Omar/Dane%20aplikacji/Thunderbird/Profiles/vonibpov.Testowy/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapCalendar.js
Line: 157



lightning: 2006122004

Comment 1

12 years ago
I try to reproduce this bug in the latest nightly builds (checked at Windows XP and Suse 10.1). I get the "insecure login" dialog only one time. And I get no errors in the java script console. So it works for me.

@Omar B -> Please, try to reproduce this bug a second time with the latest build.    
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

12 years ago
You're right. I cannot reproduce it again.

Comment 3

12 years ago
Ok, I close this bug
Resolution: WORKSFORME → FIXED

Comment 4

12 years ago
.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.