Fail to open tabs if defined: .tabbrowser-strip[collapsed="true"] * {display: none}

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: ogirtd, Unassigned)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-09-15])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

While using RTL language pack + "Always show the tab bar" option isn't checked, anding the line:
.tabbrowser-strip[collapsed="true"] * {display: none !important}
into userChrome.css causing en error if trying to open new tabs:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIScrollBoxObject.scrollBy]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/bindings/tabbrowser.xml :: addTab :: line 1150"  data: no]

Reproducible: Always
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
Version: unspecified → 2.0 Branch
(Reporter)

Comment 2

12 years ago
I still see the problem, Firefox 2.0.0.4.
The error in the Error Console now points to line 1151.

Updated

12 years ago
Whiteboard: CLOSEME 07/14
(Reporter)

Updated

12 years ago
Keywords: qawanted

Comment 3

12 years ago
It's because we try to scroll the tabbar before unsetting the collapsed attribute. http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/toolkit/content/widgets/tabbrowser.xml&rev=1.230&mark=1171,1172,1215,1216#1163
Is there a reason you've added this CSS?
Keywords: qawanted
OS: Windows XP → All
Hardware: PC → All
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> Is there a reason you've added this CSS?
Yes, I wanted to use it in one of the Firefox themes I'm maintaining. It was a good solution, but I didn't used it because RTL users will suffer from this bug and therefore couldn't use my theme.

Is there a chance this will be fixed for 3.0?
This bug was originally reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.8 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Whiteboard: [CLOSEME 2010-09-15]
(Reporter)

Comment 6

8 years ago
Seems ok under XP using 3.6.9 & RTL language pack.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.