On a multiple monitor Mac, all window colors are VERY wrong.

RESOLVED FIXED in M18

Status

()

defect
P1
major
RESOLVED FIXED
19 years ago
15 years ago

People

(Reporter: rejemy, Assigned: saari)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-]macos, )

Reporter

Description

19 years ago
When two monitors hooked up, all mozilla windows have severe color problems. The 
window backgrounds are always black, and most text elements are black as well. 
The only other color that seems to come through is dark blue. This happens in 
browser windows, the preference window, ANY mozilla window, and is makes the 
window completely illegible.

Tested with a PowerBook G3/400, MacOS 9.0.4 (with CarbonLib 1.0.3)
The problem occurs in both M15 and 4/19's nightly M16 build.

Comment 1

19 years ago
updating component and owner
Assignee: asadotzler → trudelle
Component: Browser-General → XP Toolkit/Widgets
QA Contact: jelwell → jrgm

Comment 2

19 years ago
reassigning to pinkerton for triage, since he has 2 monitors on his Mac
Assignee: trudelle → pinkerton
i don't see this on my mac, but saari does on his. chris, can you look into this? 
if you don't have time, i'll take it back, but expect me in your cube bugging you 
;)
Assignee: pinkerton → saari
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee

Updated

19 years ago
Status: NEW → ASSIGNED
Priority: P3 → P1
Target Milestone: --- → M16
Assignee

Updated

19 years ago
Keywords: nsbeta2

Comment 4

19 years ago
Putting on [nsbeta2+] radar.
Whiteboard: [nsbeta2+]
This is related to bug 6061. We need to deal with multiple monitors and bit depth 
changes better.

Updated

19 years ago
Blocks: 40158

Comment 6

19 years ago
Mass-moving undated nsbeta2+ bugs to M18
Target Milestone: M16 → M18
I think this is a dup, or at least related, to bug 6061.
Depends on: 6061
No longer depends on: 6061
Assignee

Updated

19 years ago
Whiteboard: [nsbeta2+] → [nsbeta2+]macos
Assignee

Comment 8

19 years ago
Fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 9

19 years ago
Doesn't fit latest 'would ya pull it off the wire' criteria, marking nsbeta2- in
case it gets reopened.
Whiteboard: [nsbeta2+]macos → [nsbeta2-]macos

Updated

15 years ago
OS: Mac System 9.x
You need to log in before you can comment on or make changes to this bug.