Windows x64 porting of bug 349002 - Refactor xptcall into a frozen API

RESOLVED FIXED

Status

()

RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: m_kato, Unassigned)

Tracking

Trunk
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; WOW64; SV1; .NET CLR 2.0.50727)
Build Identifier: 

Due to a fix of bug 349002, some API is changed.  But since Windows x64 code isn't updated, it will be build break.

Reproducible: Always
(Reporter)

Comment 1

12 years ago
Created attachment 249449 [details] [diff] [review]
a patch for Windows x64

Comment 2

12 years ago
Comment on attachment 249449 [details] [diff] [review]
a patch for Windows x64

>Index: win32/xptcinvoke_x86_64.cpp

>-extern "C"
>-XPTC_PUBLIC_API(nsresult)
>-XPTC_InvokeByIndex(nsISupports* that, PRUint32 methodIndex,
>+extern "C" NS_EXPORT
>+nsresult NS_FROZENCALL

Is there any particular reason you're not using XPCOM_API like the header does? http://lxr.mozilla.org/mozilla/source/xpcom/reflect/xptcall/public/xptcall.h#187

The rest of this looks fine.

--BDS

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

12 years ago
Attachment #249449 - Flags: review?(timeless)
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> (From update of attachment 249449 [details] [diff] [review] [edit])
> >Index: win32/xptcinvoke_x86_64.cpp
> >-extern "C"
> >-XPTC_PUBLIC_API(nsresult)
> >-XPTC_InvokeByIndex(nsISupports* that, PRUint32 methodIndex,
> >+extern "C" NS_EXPORT
> >+nsresult NS_FROZENCALL
> Is there any particular reason you're not using XPCOM_API like the header does?
> http://lxr.mozilla.org/mozilla/source/xpcom/reflect/xptcall/public/xptcall.h#187
> The rest of this looks fine.
> --BDS

It is same style of win32 code (xptcinvole.cpp).  If I have to use XPCOM_API like the header, I fix a patch.

If I have to use it, why doesn't win32 code use XPCOM_API like header?

Comment 4

12 years ago
> It is same style of win32 code (xptcinvole.cpp).  If I have to use XPCOM_API
> like the header, I fix a patch.

Yes, please submit a new patch.

> If I have to use it, why doesn't win32 code use XPCOM_API like header?

Because it requires the __declspec(naked) attribute.
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> > It is same style of win32 code (xptcinvole.cpp).  If I have to use XPCOM_API
> > like the header, I fix a patch.
> 
> Yes, please submit a new patch.
> 
> > If I have to use it, why doesn't win32 code use XPCOM_API like header?
> 
> Because it requires the __declspec(naked) attribute.
> 

OK.  I will submit new patch
(Reporter)

Comment 6

12 years ago
Created attachment 249490 [details] [diff] [review]
a patch for Windows x64
Attachment #249449 - Attachment is obsolete: true
Attachment #249449 - Flags: review?(timeless)
(Reporter)

Updated

12 years ago
Attachment #249490 - Flags: review?(benjamin)

Updated

12 years ago
Attachment #249490 - Flags: review?(benjamin) → review+

Updated

12 years ago
Whiteboard: [checkin needed]
(Reporter)

Updated

12 years ago
Attachment #249490 - Flags: superreview?(dougt)

Comment 7

12 years ago
Comment on attachment 249490 [details] [diff] [review]
a patch for Windows x64

looks fine.
Attachment #249490 - Flags: superreview?(dougt) → superreview+
(Reporter)

Comment 8

12 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
You need to log in before you can comment on or make changes to this bug.