Can't create an event in a time zone other than current time zone

RESOLVED DUPLICATE of bug 363111

Status

--
enhancement
RESOLVED DUPLICATE of bug 363111
12 years ago
12 years ago

People

(Reporter: gessel, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

The UI for creating an event does not permit creating an event in a time zone other than the current time zone.  People who travel must schedule events in places they will be in, which are sometimes in different time zones.  Those events are typically listed in the local time zone.  The UI should permit calendering the event in the time zone it will happen in.

The start and end times should be specifiable in their own time zones to accommodate calendaring flights, for example, where the departure and arrival times are provided by the airline in local time zones.   

Note too that the time zone selection tab is badly borked in that the list of possible cities or localities vastly exceeds the number of time zones in the world.  See separate bug report.

Reproducible: Always

Steps to Reproduce:
1. Create an event in a different time zone
2. scrunch up brow trying to remember if you should add or subtract hours
3.

Actual Results:  
Set the event in the wrong time, miss it.

Expected Results:  
Be able to set the event start and end times in the time zone that they happen in and have the computer do the math correctly.
The new prototype event dialog supports this feature. Is this an applicable feature request for the basic event dialog?
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
(Reporter)

Comment 2

12 years ago
Yes, i believe it is.  I would propose that the interface should always support either a "favorites" sublist of timezones for both the start and end of an event (preferable) or a full list of time zones, defaulting to the current system time zone.  It seems superfluous until one changes time zones a few times in a week and has to schedule events in time zones one will be in later and you get the addition wrong... embarrassing.
Severity: normal → enhancement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 363111
You need to log in before you can comment on or make changes to this bug.