Z-Order is not maintained beyond one tab

RESOLVED DUPLICATE of bug 514796

Status

()

defect
RESOLVED DUPLICATE of bug 514796
13 years ago
10 years ago

People

(Reporter: andrew.ramage, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20061204 GranParadiso/3.0a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20061204 GranParadiso/3.0a1

When multiple tabs are open (for example, Webmail, Pandora.com and various other sites) clicking on a link will open a new tab.  Closing that tab will return you to the originating page.  However, closing _that_ tab will bring the last tab to focus, not the tab next in z-order.

Reproducible: Always
Blocks: 345028
*** Bug 364824 has been marked as a duplicate of this bug. ***
Version: unspecified → Trunk
confiming
Dao, is that fixed by the patch on bug 465673?
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 345352
No longer blocks: 345028
to my understanding this bug is not a duplicate of 345352, nor is it resolved.

i will try to rephrase the problem:

if parent opens child, closing child will go back to parent

however if parent opens child opens grandchild, closing grandchild will go back to child, but closing child will not go back to parent.

this may be resolved as a side effect of fixing both Bug 514796 and Bug 514310.
now that bug 514796 is a wontfix, the current bug still stands for itself.

however i did notice that even if the child tab opens a link with middle-click it loses its parent. therefore not maintaining parenting rules beyond one generation may be by design.
see also comment #6 by Mike Beltzner in Bug 514796

IMHO, this bug should be changed to WONTFIX
You are right. Given his comment both bugs are related how to deal with closing tabs and obeying their parents. Instead of resolving this bug as wontfix we should dupe it better against bug 514796.
Duplicate of bug: 514796
i still believe that this bug stands for itself, but if it must be duped a better dupe would be bug 344508
also Bug 327562 is more relevant for the dupe.
You need to log in before you can comment on or make changes to this bug.