Firefox stopped connecting to any website after a patch upgrade on 19/20/21st Dec '06

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: deb.chatterjee, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-CA; rv:1.7.5) Gecko/20050817 Netscape/8.0.3.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1 Creative ZENcast v1.01.06

Firefox was working fine till the date mentioned above. On this day, a patch was automatically installed and Firefox was restarted. On restart, Firefox wouldnt connect to any website. Absolutely none. IE 7, Netscape 8 and Opera 9 could connect to the same websites at the same time, but Firefox couldnt. Uninstalling and re-installing did not help. Neither did reverting to old versions of Firefox. Starting Firefox in Safe mode did not work either. I have gone through FAQs, discussion forums and tweaking Anti Virus, Zone Alarms, Firewalls etc and the recommendations there do not help.

Reproducible: Always

Steps to Reproduce:
1. On a Windows XP Home (HP Pavillion dv2020ca laptop running AMD Turion 64 X2 Mobile Processor) have a Firefox installation prior to 2.0.0.1 - may be 1.5.
2. Install the latest patch released 19/20/21st and let Firefox restart.


Actual Results:  
1. On Restart, firefox fails to connect to any website.
2. Revert to any previous version, and even they cannot connect.

Following appears as a message on the centre of the page with heading - Problem loading page and none of the message below is accurate.

Unable to connect

      

      
      
      

      
        
        

          

Firefox can't establish a connection to the server at en-us.www.mozilla.com.

        


        
        


    *   The site could be temporarily unavailable or too busy. Try again in a few
          moments.

    *   If you are unable to load any pages, check your computer's network
          connection.

    *   If your computer or network is protected by a firewall or proxy, make sure
          that Firefox is permitted to access the Web.

Expected Results:  
Firefox should have continued to connect to websites as usual.


Firefox failed to connect to any site
*** Bug 364848 has been marked as a duplicate of this bug. ***
Please copy the Mozilla Firefox folder from Program Files to your desktop and try this one in stead. Does that help? You should get an alert from your firewall.

Comment 3

12 years ago
Retporter: when your firefox is updated, you must configure the firewall to recognize the new version. The firewall thinks it's a /different/ application after the update !
(Reporter)

Comment 4

12 years ago
(In reply to comment #2)
> Please copy the Mozilla Firefox folder from Program Files to your desktop and
> try this one in stead. Does that help? You should get an alert from your
> firewall.

I "copied" the Mozilla Firefox folder to desktop and I did not get an alert from the firewall. I then "moved" the entire folder and still did not get any alert. Please advice. 
Summary: Firefox stopped connecting to any website after a path upgrade on 19/20/21st Dec '06 → Firefox stopped connecting to any website after a patch upgrade on 19/20/21st Dec '06
(Reporter)

Comment 5

12 years ago
Created attachment 249580 [details]
Screen shot showing Firewall configuration for Mozilla Firefox

I have added a screen shot that shows the firewall configuration for Firefox. Permit All setting allows Firewall to access internet and hence Firewall setting should not be cause of the problem I mentioned in the bug. Windows XP Firewall is disabled on my computer.
These problems are usually caused by a firewall blocking access to the internet. Normally a firewall asks for permission when an unknown or updated application wants to access the internet, but probably the firewall is blocking the program silently from all locations. Try asking it on a Zonealarm forum or try another firewall.
(Reporter)

Comment 7

12 years ago
(In reply to comment #6)
> These problems are usually caused by a firewall blocking access to the
> internet. Normally a firewall asks for permission when an unknown or updated
> application wants to access the internet, but probably the firewall is blocking
> the program silently from all locations. Try asking it on a Zonealarm forum or
> try another firewall.

Please see the attachment that shows Norton Firewall, giving full access to Mozilla Firefox.
(Reporter)

Comment 8

12 years ago
(In reply to comment #7)
> (In reply to comment #6)
> > These problems are usually caused by a firewall blocking access to the
> > internet. Normally a firewall asks for permission when an unknown or updated
> > application wants to access the internet, but probably the firewall is blocking
> > the program silently from all locations. Try asking it on a Zonealarm forum or
> > try another firewall.
> 
> Please see the attachment that shows Norton Firewall, giving full access to
> Mozilla Firefox.
> 
Firefox started working as suddenly as it had stopped working. I did not touch any configuration in any application.

Comment 9

12 years ago
Debashish, if a bug no longer fails then you can close it as INVALID (if the problem probably wasn't caused by mozilla), FIXED (if you know which other bug with a patch fixed it for you), or WORKSFORME (if you know it was a mozilla problem but don't know what fixed it)

looks to me like INVALID. closing so.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Reporter)

Updated

12 years ago
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.