If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

using tools corrupts profiles causing crashes specific to Tools> Options

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
critical
RESOLVED INCOMPLETE
11 years ago
9 years ago

People

(Reporter: david, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20061223 Minefield/3.0a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20061223 Minefield/3.0a2pre

Making changes using tools is permanently corrupting both original and new profiles causing crashes when clicking on Tools> Options, but only after the program is started again following the changes. 

Reproducible: Always

Steps to Reproduce:
1. make minor/normal changes using tools
2. click on Tools> Options


Actual Results:  
Before the Options window opens the program crashes


Expected Results:  
Options window opens

I wanted to create a new profile since I'd not done one in years and had added/removed bunches of extensions, thus a clean fresh start for the latest nightlies.
Here's what happened initially and what I've tried since:

Created a new profile via Profile Mgr.
Closed Minefield.
Manually moved old bookmarks from old profile to new (via windows explorer)
Started.
Clicked on "Options" and Minefield crashed.
Went back, manually removed bookmarks.
Restarted.
Clicked on "Tools> Options" and Minefield promptly crashed/closed (Options window did not even open: ref bug 328513?).

Removed new profile via Profile Mgr.
Deleted that profile folder via Windows Explorer.
Created another new profile (different name).
Imported old bookmarks via Bookmarks> Organize> Import.
Verified import.
Clicked on "Options" and Minefield crashed/closed.

Started with original/old profile where bookmarks were copied/imported from.
Clicked on "Options" and Minefield crashed.

Verified via ProcessExplorer/Task Manager that no Minefields were running in the background.
Started Mindfield again.
Deleted new profile.
Selected old profile and started.
Clicked on "Options" and Minefield crashed.

Started again under original profile.
Checked random bookmarks; they loaded fine.
Checked "Organize Bookmarks"; it opened/closed.
"Tools> Clear Private Data" and "Tools> Add-ons" work.
I have the TabMix Plus add-on installed; clicked "Tools> TabMix Options"; worked fine.
Closed Minefield without clicking "Options".
Started again; created another new profile.
Clicked Tools> Options, no crash.
Closed.
Restarted with new profile.
Clicked on "Options", everything normal.
Imported original bookmarks in this profile.
Checked & loaded a couple of them.
Clicked on "Options" and again everything normal.
Closed.
Started.
Clicked on "Options" and Minefield crashed.

Created new profile
Started with new profile, clicked Tools>Options; normal
Opened bookmarks/closed.
Started, clicked Tools>Options; normal
Closed Minefield
Started again
Clicked on Tools>Options; normal
Opened web page; added it to Bookmarks
Clicked Tools>Options = crash

Deleted new profile
Created another new profile
Clicked Tools> Options; normal
Changed for test, to "Show a blank page" under Main menu
Opened/closed Tools>Dom Insp and 
*Did nothing with bookmarks*
Closed
Started with newest profile
Clicked Tools> Options; crashed


Status:  Can not use "Tools> Options" under original profile any longer, nor new profiles more than once after minor changes are made using tools; individual bookmarks work fine as seems most other functions (I used my original profile/bookmark to post this bug report).

Summary: appears that something in tools usage/changes is permanently corrupting profiles relative to Tools>Options rendering Options unusable?

Note again: Prior to creating the new profile bookmarks & Options had been working fine in the original profile.  Sample individual bookmarks that I checked loaded fine in both new and original profiles.
Again, I only created a new profile in hopes of getting a fresh start from bunches of extension adds/removes.

This sounded similar to Bug 357770 but with my original profile TalkBack is disabled.  TalkBack did work with new profiles (and I sent four of them; apologies tho, as I failed to catch the numbers; they do have my email address in them, as is logged here on the board).


Add-ons/Extensions:
New Profiles = none
(Reporter)

Comment 1

11 years ago
Latest: I have not been able to replicate this crash problem using either my original nor a new profile when in Safe Mode and following similar steps/actions.
(Reporter)

Comment 2

11 years ago
Latest:
I did a nightly update (from Safe Mode)
Restarted in my original profile; clicked Tools> Options and everything worked normally!  I tried it several times and everything else tested worked correctly.  I then closed it and opened it under my new profile.  
Clicked Tools> Options and it crashed as before-- except this time it never closed and instead showed the "not responding" msg in the header.  So with it frozen I clicked the "close" X and it closed.  
I went back and started in my original profile; clicked Tools> Options and it too again crashed and also gave the "not responding" msg requiring a manual close.
??
(Reporter)

Comment 3

11 years ago
Latest:
This one gets stranger and stranger!

For the last couple of nightly updates my original (oldest) profile now works normally regarding the Tools> Options (no longer crashing Minefield).

However, I today created a new profile (with no extensions/add-ons) and the basic problem reported originally in the bug occurs with it!
ie:
I first modified some options in the Tools> Options window; restarted & repeated and no crashes.
I then imported my bookmarks, cliked Tools> Options and it crashed.  [note, that in the original bug post, other modifications would cause the same thing, seeming to eliminate the book marks themselves as the culprit...?]

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20061227 Minefield/3.0a2pre - Build ID: 2006122704
reporter, Do you still see this problem. If you do not, please close the bug with resolution WORKSFORME, INVALID, etc as may be appropriate to your situation (but not FIXED unless you know the bug with the patch). 

If you still see problem using a current version of Firefox or trunk build, please provide additional detail.
Whiteboard: closeme 2008-12-10
@Reporter, we have not heard back from you in a while, so I am closing this bug as INCOMPLETE. You can reopen this bug if more information becomes available. Some helpful information you can provide us is found at http://quality.mozilla.org/bug-writing-guidelines.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
Whiteboard: closeme 2008-12-10
Version: unspecified → 3.0 Branch
You need to log in before you can comment on or make changes to this bug.