After new email downloaded message view and email View plane out of sync, crashes when trying to exit the app

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: jg, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
I am running Edgy Kubuntu Thunderbird 1.5.0.8. This same problem was present in Kubuntu 6.06 with Thunderbird 1.5.0.7 and 1.5.0.8 on that distro release.

1) Download messages from account
2) Browse any folder, Inbox, Drafts etc.
3) See that the plane is out of sync
4) See if you open a Draft email that the to: address has been changed to the Draft below.
5) Sometimes the Message View plane does not renderer anything (presumably because it is so out of sync that it cannot even pick the wrong email to display?)
6) Close all windows and restart, often crashes while closing windows, so i have to save any windows with composed text to Drafts so they are not lost.

Comment 1

12 years ago
Can you try an official build from mozilla.org? 1.5.0.9, or better yet - a nightly build. If it still crashes, provide the talkback id of the crash. 
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-mozilla1.8/
(Reporter)

Comment 2

12 years ago
Hi Magnus,
I can't spot an Ubuntu/Deb package on that link at present. Are their debug symbols available for the Edgy Ubuntu package somewhere? I looked but only libxul0d-dbg was available at present. (I've installed this and will try get a backtrace if it crashes again)

Jon
p.s.
I've not found a way to start mozilla-thunderbird from gdb, it seems to use a script which means I have to start it and then attach to the PID at present. If that could be switched from a script to a binary like other applications that would be great.

Comment 3

12 years ago
if you're using standard mozilla.org builds:

./run-mozilla.sh -g -d gdb ./thunderbird-bin

if you aren't, all bets are off. vendors have been known to hack the stuffing out of our files to the point that they are not recognizable.
(Reporter)

Comment 4

12 years ago
Hi, Thanks for the gdb tip.  I could not reproduce it when I tried a Mozilla Thunderbird build. I'll try get a backtrace if it occurs in the Ubuntu build. If Mozilla could encourage vendors to ship packages with debug symbols that would help getting meaningful backtraces etc..
Cheers, Jon

Comment 5

12 years ago
->WFM since the mozilla.org build don't crash per comment 4.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.