Searching in search bar is not possible when profile path is not accessible anymore

RESOLVED WORKSFORME

Status

()

Firefox
Search
RESOLVED WORKSFORME
12 years ago
3 years ago

People

(Reporter: Siarhei Vaurynovich, Unassigned)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061208 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061208 Firefox/2.0.0.1

We use Kerberos tickets to authenticate in the system. After a ticket expires files on hard drive (i.e. home directory in which .mozilla directory is) become unaccessible. After getting a new Kerberos ticket the search engines (Ctrl+K) in firefox do not work any more, i.e. if I try to search for anything, just NOTHING happens (it is even not possible to change the current search engine to any other in the list). Restarting firefox restores full search functionality.


Reproducible: Always

Steps to Reproduce:
1. On a system which uses Kerberos tickets (http://web.mit.edu/Kerberos/) for authentication (used in all research organizations in physics at least) start firefox.
2. Wait till your current Kerberos ticket expires.
3. Renew your Kerberos ticket - everything is accessible again and works except firefox search engines.

Actual Results:  
Firefox search engines completely loose functionality. Restarting firefox restores full search functionality.


Expected Results:  
Firefox search engines functionality is restored after the home directory (.mozilla) access regained.
Can you set javascript.options.showInConsole and browser.search.log to true using about:config (http://kb.mozillazine.org/About:config if you're not familiar), and paste any relevant Error Console messages or exceptions that occur after reproducing the bug?
(Reporter)

Comment 2

12 years ago
Hello,

Here are the relevant Error Console messages 
(they were repeated many times, I selected only the 4 unique those,
to make sure I do not loose any messages I restarted firefox and without
loading any page just waited till the current Kerberos ticket expires
so below are ALL the different error messages I could find except one 
live bookmark page error):

/***************************************************************/

getEngines: getting all engines

Error: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.moveTo]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: file:///afs/lns.mit.edu/user/vaurynov/.mozilla/firefox/6wtwvpzv.default/extensions/%7B0538E3E3-7E9B-4d49-8831-A227C80A7AD3%7D/components/ffDisk.js :: ffDisk_move :: line 176"  data: no]
Source File: file:///afs/lns.mit.edu/user/vaurynov/.mozilla/firefox/6wtwvpzv.default/extensions/%7B0538E3E3-7E9B-4d49-8831-A227C80A7AD3%7D/components/ffDisk.js
Line: 176

Error: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.moveTo]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: file:///afs/lns.mit.edu/user/vaurynov/.mozilla/firefox/6wtwvpzv.default/extensions/%7B0538E3E3-7E9B-4d49-8831-A227C80A7AD3%7D/components/ffDisk.js :: DiskWriter__move :: line 563"  data: no]
Source File: file:///afs/lns.mit.edu/user/vaurynov/.mozilla/firefox/6wtwvpzv.default/extensions/%7B0538E3E3-7E9B-4d49-8831-A227C80A7AD3%7D/components/ffDisk.js
Line: 563

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageStatementWrapper.step]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///usr/local/bin/firefox/components/nsSearchService.js :: epsGetAttr :: line 2845"  data: no]
Source File: file:///usr/local/bin/firefox/components/nsSearchService.js
Line: 2845

/***************************************************************/

Siarhei.
Assignee: nobody → gavin.sharp
This is still relevant and easily to reproduce.

Steps:
1. Create a new profile on an USB stick
2. Start Miinefield with this profile
3. Remove the stick
4. Hit Ctrl/Cmd+K to focus the search bar
5. Enter a term and press enter

After step 5 the following error appears. It's the last one from the former comment with slightly changed lines:

Error: [Exception... "Component returned failure code: 0x80630002 [mozIStorageStatementWrapper.step]"  nsresult: "0x80630002 (<unknown>)"  location: "JS frame :: file:///Applications/Minefield.app/Contents/MacOS/components/nsSearchService.js :: epsGetAttr :: line 3244"  data: no]
Source File: file:///Applications/Minefield.app/Contents/MacOS/components/nsSearchService.js
Line: 3244

Gavin, you are assigned to this bug? Have you planned to work on it some years ago?

Tested with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090517 Minefield/3.6a1pre
Severity: minor → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86 → All
Version: unspecified → 2.0 Branch
Summary: Search engines (Ctrl+K) stop working after interruption in hard drive accessibility. → Searching in search bar is not possible when profile path is not accessible anymore
Duplicate of this bug: 380276
Assignee: gavin.sharp → nobody
Profiles disappearing isn't something that the rest of the browser handles very well, I can't imagine this being the only problem in those cases. We could probably make DB accesses fail gracefully, though (in some cases they aren't needed for search results).
The error message here comes from the mozIStorageStatementWrapper.step call, which has been removed in bug 699856.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.