crash when attempting to modify columns in "Manage Bookmarks..."

VERIFIED DUPLICATE of bug 33524

Status

P3
critical
VERIFIED DUPLICATE of bug 33524
19 years ago
14 years ago

People

(Reporter: bri, Assigned: slamm)

Tracking

Trunk
PowerPC
All

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Mac_PowerPC)
BuildID:    2000041805

in Manage Bookmarks..., if you deselect (uncheck) any item from the 
pulldown (e.g. URL, Added On, Last Modified, etc) then attempt to 
deselect any other, Mozilla will crash.

Reproducible: Always
Steps to Reproduce:
1. choose Manage Bookmarks...
2. in the Bookmarks window from the pulldown widget (top, far right 
column) deselect any item.
3. deselect another item.

Actual Results:  Mozilla drops into macsBug (quits with type 2 error 
otherwise)

Expected Results:  allowed further deselection.

log from macsBug:

PowerPC unmapped memory exception at DF1CF84C
 Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  1FC9A47C  
  0EE56E80    PPC  1FC8DA98  
  0EE56DF0    PPC  1FC8D54C  
  0EE56D00    PPC  1F0BB63C  
nsGetServiceByProgID::~nsGetServiceByProgID()+00248
  0EE56CC0    PPC  1F0318F0  
nsMacMessageSink::IsRaptorWindow(GrafPort*)+014DC
  0EE56C70    PPC  1F031D88  
nsMacMessageSink::IsRaptorWindow(GrafPort*)+01974
  0EE56C20    PPC  1F031FDC  
nsMacMessageSink::IsRaptorWindow(GrafPort*)+01BC8
  0EE56BD0    PPC  1F032B1C  
nsMacMessageSink::IsRaptorWindow(GrafPort*)+02708
  0EE56B80    PPC  1F032830  
nsMacMessageSink::IsRaptorWindow(GrafPort*)+0241C
  0EE56B30    PPC  1F032B74  
nsMacMessageSink::IsRaptorWindow(GrafPort*)+02760
  0EE56AE0    PPC  1F030260  
nsMacMessageSink::DispatchOSEvent(EventRecord&, GrafPort*)+00038
  0EE56AA0    PPC  1F02C70C  NSGetFactory+0D9E4
  0EE56A60    PPC  1F02D048  NSGetFactory+0E320
  0EE56A10    PPC  1F02E35C  NSGetFactory+0F634
  0EE56970    PPC  1F01C2A0  
  0EE56910    PPC  1F01C1EC  
  0EE568D0    PPC  1F01C164  
  0EE56880    PPC  1D14B8BC  NSGetModule+06D24
  0EE56830    PPC  1D152B2C  NSGetModule+0DF94
  0EE56700    PPC  1D14D128  NSGetModule+08590
  0EE56680    PPC  1D14D1B4  NSGetModule+0861C
  0EE56600    PPC  1DC13F9C  
NS_NewPresShell(nsIPresShell**)+0610C
  0EE56580    PPC  1DC99E14  
NS_NewEventListenerManager(nsIEventListenerManager**)+00D80
  0EE56050    PPC  1DC9BBAC  
NS_NewEventListenerManager(nsIEventListenerManager**)+02B18
  0EE55FB0    PPC  1DDDCE54  nsStyleChangeList::Clear()+03400
  0EE55F60    PPC  1DC08AC8  nsGetInterface::~nsGetInterface()+07774
  0EE55F10    PPC  1DDDCE54  nsStyleChangeList::Clear()+03400
  0EE55EC0    PPC  1DC08AC8  nsGetInterface::~nsGetInterface()+07774
  0EE55E70    PPC  1DDDCE54  nsStyleChangeList::Clear()+03400
  0EE55E20    PPC  1DC08AC8  nsGetInterface::~nsGetInterface()+07774
  0EE55DD0    PPC  1DDB9874  
NS_NewNameSpaceManager(nsINameSpaceManager**)+1F1C4
  0EE55D80    PPC  1DDB97EC  
NS_NewNameSpaceManager(nsINameSpaceManager**)+1F13C

Comment 1

19 years ago
Reproducable on Win98 Build 2000041915

Comment 2

19 years ago


*** This bug has been marked as a duplicate of 33524 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 3

19 years ago
really a dupe of bug 30152 which leads to bug 33524. VERIFIED Dupe.
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
evola, your crash is with an M16 build? not an m15 branch build?

Comment 5

19 years ago
ignore my last comment, wrong bug.
Product: Browser → Seamonkey

Updated

14 years ago
OS: All
You need to log in before you can comment on or make changes to this bug.