Corrupt mail from delete, to undelete

RESOLVED DUPLICATE of bug 209189

Status

defect
--
critical
RESOLVED DUPLICATE of bug 209189
13 years ago
11 years ago

People

(Reporter: Wayne, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: Thunderbird version 1.5.0.9 (20061207)

I got a ton of the usual junk mail, and I deleted it, and then decided to undelete it. I clicked "undo delete", and nothing happened, clicked it again and nothing happened, clicked it a 3rd time, and waited, and then it started showing the mail back, but it was corrupt. It contained no body, and no subject, and the date was something like 1969 7:00am. Then trying to delete that junk was clumsy. I had to do multiple deletes just to get it out of the in box, and then started sending myself some test mail, and clearing that through, to get things cleaned up and working properly.


Reproducible: Didn't try

Steps to Reproduce:
1. Get Lot's of junk mail
2. Delete all junk mail
3. Click edit, "undo deleted message"
4. click it again because nothing happened
5. repeat step 4
6. corrupt e-mail as undeleted mail shows up with date something like 1969 7:00am

7. you have a mess trying to clean it up because it does not want to delete properly
Actual Results:  
You have a mess of corrupt e-mail and even it is difficult to clean up.

Expected Results:  
Mail undeleted.

multiple clicking of the "undo delete message" may have caused this bug to rear it's ugly head.
Wayne, ever seen this again?
Reporter

Comment 2

12 years ago
No, I have not dare tried it again. If I accidentally erase an e-mail, I just go to the trashcan and *move* it to the in-box.

Wayne Sallee
Wayne@WayneSallee.com

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 209189
You need to log in before you can comment on or make changes to this bug.