crash when subscribe remote calendar (and use my local)

VERIFIED DUPLICATE of bug 364900

Status

Calendar
Import and Export
--
critical
VERIFIED DUPLICATE of bug 364900
12 years ago
12 years ago

People

(Reporter: Damian Szczepanik, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20061225 Calendar/0.4a1

I've subscribed remote calendar and Sunbird crashed. Looks like there is something wrong with my data.
I can say that only this duet causes Sunbird crash

Reproducible: Always

Steps to Reproduce:
1. subscribe https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=&long_desc_type=allwordssubstr&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&emailtype1=exact&email1=&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=13%3A20&chfieldto=Now&chfieldvalue=&field0-0-0=noop&type0-0-0=noop&value0-0-0=&ctype=csv this is not iCalendar format but anyway crash is not nice

Actual Results:  

[Exception... "Component returned failure code: 0x804a0107 [calIICSService.parseICS]"  nsresult: "0x804a0107 (<unknown>)"  location: "JS frame :: file:///C:/Sunbird/components/calICSCalendar.js :: anonymous :: line 245"  data: no]

after restart goto tools -> options

TB27736486
TB27736944


How can I check if events in my calendar are valid? I exported and imported the events to new profile but no wornings and errors

This happens only with my private calendar but I would rather not to publish it...

I probably can remove all summary and descr but not sure if when Sunbird will crash - I use nightly version and some data might not be stored/converted properly so maybe the problem is somewhere else?
(Reporter)

Comment 1

12 years ago
Created attachment 249647 [details]
profile which crashes

Let me attach the profile without events (I removed all of them) but the problem still exists
According to the stack trace this is a duplicate of Bug 364900.

*** This bug has been marked as a duplicate of 364900 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> According to the stack trace this is a duplicate of Bug 364900.

yes, works again
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.