Last Comment Bug 365180 - no new mail notification if some new messages are spam
: no new mail notification if some new messages are spam
Status: RESOLVED INCOMPLETE
relnote-seamonkey1.1
: regression
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Message Display (show other bugs)
: SeaMonkey 1.1 Branch
: x86 Windows 95
: -- normal with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-27 15:16 PST by Benoît
Modified: 2014-06-09 20:50 PDT (History)
11 users (show)
antoine.mechelynck: needinfo? (benoit)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Benoît 2006-12-27 15:16:12 PST
For a long time the new mail notification has been very inconsistent, and I think I've tracked down the cause. When there is new mail, but there was also junk mail (detected as such and moved to Junk), there is no notification of new mail. If only new mail arrives, the notification is shown.

I've been trying to get a regression range on this, but the SPAM isn't cooperating (as in not arriving) at the moment.

This happens on Windows with a recent 1.8.1 branch build.
Comment 1 Wayne Mery (:wsmwk, NI for questions) 2006-12-31 11:25:45 PST
related to the citations in bug 233930?
Comment 2 Benoît 2007-01-02 16:28:43 PST
Thanks to CTho's excellent suggestion, I was able to track this down well. I've got a regression range:

20060522-04 works
20060523-16 broken

I checked bonsai for checkins to SeaMonkeyMailNews in that time frame. bug 257990 to blame?

While searching for this regression range, I noticed that in addition to not showing the new mail notification, the SPAM message is marked as read even though the option to mark it as read when detected is not on.
Comment 3 Benoît 2007-01-06 13:12:02 PST
The conspiracy against Win9x continues, as I can't reproduce this on WinXP using the exact same method.
Comment 4 Mike Cowperthwaite 2007-01-06 13:25:40 PST
When you say "no notification of new mail" does that mean you don't get the tray icon, the alert (slide-up window/sound), or both?
Comment 5 Benoît 2007-01-06 13:29:07 PST
It means that I don't get a new mail notification of any kind. No tray icon, no slide-up window, and no sound. Nothing. :(

It means that often when I check my inbox I find mail waiting for me that SeaMonkey didn't alert me of.
Comment 6 Mike Cowperthwaite 2007-01-06 13:33:27 PST
Is the Inbox folder not boldfaced?  (Or do you have the account collapsed, or have older unread mail?)

When new messages arrive, there's a little 'new' flag put on the icon of the new messages, the folder containing the new messages, and the account to which the messages were sent.  The next time you see this, take note whether any of those flags are in place.
Comment 7 Mike Cowperthwaite 2007-01-07 23:42:25 PST
I've had my server-side spam filters turned off for a few days and finally managed to see a download that included both ham and spam, and I got the expected notification; but this was with a recent TB 3a1 (trunk) build.  I'll keep trying with 2b1.
Comment 8 Benoît 2007-01-08 07:41:29 PST
OK, saw it again.

All the new mail flags are there, except for the one on my account (not sure if it's supposed to be flagged, I have only one anyway).
Comment 9 Mike Cowperthwaite 2007-01-09 11:00:47 PST
Yes, the account *should* be flagged if new mail arrives for it.  Is this a POP or IMAP account?  If POP, is it using the Global Inbox (under Local Folders) or does it appear as its own node in the folder pane?  Other than junk controls, are you using any filters to move mail to folders other than Inbox?

I've again received mail in a batch containing both ham and spam, this time with TB 2b1-0108, and again I got all the expected notifications.  This is for a POP account that doesn't use the global inbox.
Comment 10 Benoît 2007-01-10 11:02:45 PST
It's a POP account.
I don't use the Global Inbox, the account has its own node.
I don't use any filters to move mail.
Comment 11 Worcester12345 2007-01-18 17:39:30 PST
Is this a duplicate to Bug 228649 – Unable to download mail from pop3 server caused by junk email

??
Comment 12 Benoît 2007-01-19 04:14:11 PST
Most definitely not. I can download e-mail just fine. The notification just doesn't show up if some of it is mail classified as junk.
Comment 13 Benoît 2007-02-17 06:51:35 PST
Please tell me how I can contribute to fixing this bug. I'm willing to run a debug build (I can compile one if needed), for example.
Comment 14 Benoît 2007-03-05 06:49:35 PST
Since installing SeaMonkey 1.1, this bug has been partially fixed, it seems. When open Mail & Newsgroups (auto-log-in on) and retrieve my new messages, the new mail notification works fine. But after that it fails to work under the same condictions as I outlined above.
Comment 15 Benoît 2007-06-17 08:51:57 PDT
Still on SeaMonkey 1.1 (now 1.1.2), I noticed something that may be of importance. When I get new mail, both ham and spam, the ham is marked as read, even though I didn't read it yet.
Comment 16 Wayne Mery (:wsmwk, NI for questions) 2008-02-24 05:56:02 PST
(thinks some cases of this were fixed on trunk)
Comment 17 Mike Cowperthwaite 2008-02-24 09:39:31 PST
(In reply to comment #15)
> Still on SeaMonkey 1.1 (now 1.1.2), I noticed something that may be of
> importance. When I get new mail, both ham and spam, the ham is marked as read,
> even though I didn't read it yet.

If it's marked as read then, yes, notification does not get triggered.  How it's coming to be marked as read is a question.  You said before you're not using filters; is that still the case?  (I use filters to mark some messages as read.)
Comment 18 Benoît 2008-02-24 12:06:19 PST
Yes, I'm still not using any filters.
Comment 19 Serge Gautherie (:sgautherie) 2008-05-18 08:25:08 PDT
Can you reproduce with SeaMonkey v1.1.9 ?

Are you still using Win95 ?
Comment 20 Benoît 2008-07-15 12:31:23 PDT
I can still reproduce this with SeaMonkey 1.1.11.
Yes, I'm still using Win95.
Comment 21 Tony Mechelynck [:tonymec] 2013-11-29 16:31:42 PST
- Benoît: Does this bug still happen with SeaMonkey 2.22.1 (or later, and which exact SeaMonkey version, and on which OS)?
- Can anyone reproduce this on SeaMonkey 2.25a1 for Windows, or 2.24a1 for Linux or Mac (which are the respective "latest bleeding-edge versions" per platform as of this writing)?
Comment 22 Tony Mechelynck [:tonymec] 2014-06-09 20:50:41 PDT
No answer in 5 months: resolving INCOMPLETE. This bug may be REOPENED (or set to WORKSFORME, depending) by answering coment #21; but note that versions have advanced in the meantime: the current "stable" version is 2.26, the current "bleeding-edge" version is 2.29a1 for Windows or Mac, or 2.27a1 for Linux32 or Linux64.

Note You need to log in before you can comment on or make changes to this bug.