Closed Bug 365208 Opened 14 years ago Closed 13 years ago

[reflow branch] <select> list is misplaced, its scrollbar not fully rendered

Categories

(Core :: Layout: Form Controls, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mats, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(4 files)

<select> list is misplaced, its scrollbar not fully rendered.

STEPS TO REPRODUCE
1. load bug 365103 (or any bug page that does not have a long link in it)
2. resize the window width back and forth, watch the CC list

ACTUAL RESULT
Two errors can occur:
1. the "Remove selected CCs" is placed on top of the CC list (screenshot 1)
2. the CC list is placed on top of "Add CC" and the scrollbar looks damaged
   (covering the window doesn't help) (screenshot 2)

PLATFORM AND BUILDS TESTED
Bug occurs in SeaMonkey 2006122301 on Linux
Bug occurs in SeaMonkey 2006120801 (post reflow branch) on Linux
Bug does not occur (AFAICT) in SeaMonkey 2006120701 (pre reflow branch)
Attached image Screenshot #1
Attached image Screenshot #2
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a2pre) Gecko/20061228 Minefield/3.0a2pre ID:2006122814 [cairo]

just slowly make this window narrower and look at the form controls.
The text in inputs is even moving/jumping out of of them and sometimes doesn't jump back in.
(In reply to comment #3)
> just slowly make this window narrower and look at the form controls.
> The text in inputs is even moving/jumping out of of them and sometimes doesn't
> jump back in.

I think that's bug 365294.
hmm, after Bug 243159 was backed out (2006-12-29 03:27) to fix Bug 365191 the problems acc. comment #0 are gone.

So is this still reproducible?
Flags: blocking1.9?
Is this still reproducible?
Attached image Screenshot #3
It still occurs but it's less severe now.
Load this bug report and resize the window width back and forth so that
the word "rendered" is alternating between the first and second line.

Note the text baseline error in the inside the Keywords and URL fields.
Note the CC list and the checkbox below it (or sometimes the text input
above it) have overlapping borders.
The "scrollbar rendering" part of the problem seems to be gone though.
Attached image Screenshot #4
Spoke to soon, the scrollbar rendering error still occurs too...
SeaMonkey 2007040301 Linux, Modern theme.
Flags: blocking1.9? → blocking1.9+
I haven't been able to reproduce this so far.  :(
Keywords: qawanted
Using Firefox trunk on Ubuntu Feisty with the GNOME ClearLooks theme, I couldn't reproduce this either, FWIW.

Mats, native theming of form controls on Linux got turned on recently. Can you retest? Also, can you reproduce this in Firefox, or does it only happen with the SeaMonkey modern theme?
WFM, (todays) SeaMonkey default & modern theme on Linux.
I'll reopen if I see it again... (note to self: tested using bug 290409 and
bug 344635 which are reproducible in 20061209 SeaMonkey Modern)

-> WORKSFORME
Status: NEW → RESOLVED
Closed: 13 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
Note that anything like this needs to be tested with native theming both on and off, since web pages can easily disable it (and often do).
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.