Bugzilla shows too much components in saved search

RESOLVED DUPLICATE of bug 365107

Status

()

RESOLVED DUPLICATE of bug 365107
12 years ago
12 years ago

People

(Reporter: mozilla-bugs, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5; Linux; X11; de) KHTML/3.5.5 (like Gecko)
Build Identifier: 

The default search lists the component of all products, not only those of the selected products.

To reproduce, 

If I re-select the mentioned products, the component list is shrinked to the
correct list of components. I guess the problem is that this is done using
JavaScript, not server-side.

Possible solutions:
- call the JavaScript that is run when changing product selection "onLoad" 
  also   or
- shrink the component list at server-side

The same problem appears on the "Version" field - it also contains several
version strings not belonging to the selected products.

Reproducible: Always

Steps to Reproduce:
1. go to http://landfill.bugzilla.org/bugzilla-2.22-branch/query.cgi
2. switch to "Advanced search" if not already done
3. select the following options:
   - Component: DeleteMe
   - [x] remember these as my default search options
  - other values don't matter here
4. go back to query.cgi
Actual Results:  
The component list shows lots of components, most of them belong to other products

Expected Results:  
The component list should only show the components of the selected product "DeleteMe" ("Cleanup" and "TheEnd")

Re-selecting the product is a workaround

Possible solutions:
- call the JavaScript that is run when changing product selection "onLoad" 
  also   or
- shrink the component list at server-side

This was initially reported as https://bugzilla.novell.com/show_bug.cgi?id=141030 (non-public)

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 365107

Comment 2

12 years ago
Just ignore me..
éøá
OS: Linux → All
Hardware: Other → All
You need to log in before you can comment on or make changes to this bug.