Closed Bug 365345 Opened 13 years ago Closed 13 years ago

Em-spaces ( ) are not copied

Categories

(Core :: XPCOM, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: bugzilla, Assigned: smontagu)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

When copying text which includes em-spaces (e.g. "Blithfield Reservoir. Mr. T. W. Ford") the space is not copied to the clipboard as a space.

Reproducible: Always

Steps to Reproduce:
1.Copy text including em-space
2.Paste to non-rich text application (e.g. notepad)
Actual Results:  
Pasted text has no space after the word "reservoir": "Blithfield Reservoir.Mr. T. W. Ford"

Expected Results:  
A space after the word "reservoir": "Blithfield Reservoir. Mr. T. W. Ford"

Using Win XP SP2, fully patched.
See also Bug 346969 "      do not wrap"
Not tested for other space characters (    etc.)
Assignee: nobody → dom-to-text
Component: General → DOM to Text Conversion
Product: Firefox → Core
QA Contact: general
Version: unspecified → 1.8 Branch
I suspect the problem is with Notepad and/or Windows XP rather than Firefox.
We put the Unicode character \u2003 on the clipboard, it's up to the receiver
to interpret it correctly. You can try this by pasting it to the URL bar
for example (a longer than usual space should be rendered).
Pasting it into a terminal window on Linux and then copying it from there,
pasting it back to the URL bar preserves the \u2003 character.
Copying from Firefox 2.0 to Notepad and then back on Windows Vista also works.
I can reproduce this when pasting into a non-Unicode app. on Windows.
This would be because the transliterator transliterates the various space characters to ASCII spaces, but leading and trailing spaces are trimmed from property values. I am gobsmacked that nobody noticed this or thought to test it in over 5 years.
Status: UNCONFIRMED → ASSIGNED
Component: DOM to Text Conversion → XPCOM
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Version: 1.8 Branch → Trunk
Assignee: dom-to-text → nobody
Status: ASSIGNED → NEW
QA Contact: xpcom
Assignee: nobody → smontagu
Attachment #250058 - Flags: superreview?(darin.moz)
Attachment #250058 - Flags: review?(darin.moz)
Attachment #250058 - Flags: superreview?(darin.moz)
Attachment #250058 - Flags: superreview+
Attachment #250058 - Flags: review?(darin.moz)
Attachment #250058 - Flags: review+
Checked in.
Status: NEW → RESOLVED
Closed: 13 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Is this fix the cause of Bug 378839 ?
Depends on: 378839
Backed out for the time being until after the 1.9a4 freeze.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Checked in again, including the fix for bug 378839.
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.