Status

()

--
critical
RESOLVED DUPLICATE of bug 213637
12 years ago
12 years ago

People

(Reporter: sudipta.dey, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: 2.0.0.1

Firefox starts hogging the CPU with nearly 100% usage if connect-disconnect-connect your internet connection

Reproducible: Always

Steps to Reproduce:
1. You are in some domain with connected to a wireless/LAN
2. Open Firefox and browse some sites in tabs
3. change you internet connection i.e. disconnect and connect to another wireless/LAN domain
Actual Results:  
Firefox starts hogging the CPU with nearly 100% usage with the new connection

Expected Results:  
Firefox should re-connect all the websites using the new wireless/LAN connection and behave normally as it was doing in the last connection

If I restart Firefox, it starts running fine
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0 Branch

Comment 1

12 years ago
This might make sense with what I've seen of Firefox hangs with 100% of CPU. It occurs frequently when using Neopets.com on several tabs. The occurrence today happened when someone else was using our internet connection to the point that when Neopets page tried to update, the connection was unavailable. It hung for a bit, then finally returned, still using 100% cpu, and the only way to get the CPU to go down once it's that high is to restart Firefox.

Comment 2

12 years ago
If you can reproduce this bug, please go to bug 213637
comment 57 and help me test my patch.  Thanks.

Comment 3

12 years ago
I believe this bug is a duplicate of bug 213637.  I just checked
in a fix for bug 213637.  If you're still seeing this problem,
please go to bug 213637 comment 57 and test my special Firefox
build.  Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 213637
You need to log in before you can comment on or make changes to this bug.