If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Dropping a history item into the places-based bookmarks toolbar does not bookmark it

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: mano, Assigned: mano)

Tracking

Trunk
Firefox 3 alpha2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

When a history item is dropped into the places-based bookmarks toolbar, it's not bookmarked. The user-facing result is a disabled "Get Info" item in the context menu for the item. I also see the following assertion when isBookmark is called for the dropped node:

###!!! ASSERTION: Bookmark hash table out-of-sync with the database: 'realBookmarked == *aBookmarked', file nsNavBookmarks.cpp, line 1875

This does not happen in a copy-paste sequence.
Hrm, I couldn't reproduce this again. :-/
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
asaf, I haven't seen this one yet but could it be a "which controller has focus" bug lurking?

I'll poke around to see if I can reproduce it.
No, go*Command functions are not involved here and the controller for the drag/drop actions is set explicitly (that's, this.contoller).
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.