don't give me an internal error for trying to edit a non existent account

RESOLVED FIXED in Bugzilla 4.4

Status

()

Bugzilla
Administration
--
minor
RESOLVED FIXED
12 years ago
5 years ago

People

(Reporter: timeless, Assigned: Frédéric Buclin)

Tracking

2.23.3
Bugzilla 4.4

Details

(Whiteboard: [Fixed by blocker])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

12 years ago
Bugzilla has suffered an internal error. Please save this page and send it to bugzilla-admin@mozilla.org with details of what you were doing at the time this message appeared. 

URL: https://bugzilla.mozilla.org/editusers.cgi?action=activity&userid=290075

There is no user account with ID 290075.
(Assignee)

Updated

9 years ago
Duplicate of this bug: 383432

Comment 2

8 years ago
Created attachment 450972 [details] [diff] [review]
3 file edits to fix this error.

Remember this is THREE files to edit. Diff will show it all on one file in bugzilla. Be sure to check the fulle text file.

Updated

8 years ago
Attachment #450972 - Attachment is patch: true

Comment 3

8 years ago
Created attachment 450973 [details] [diff] [review]
A fixed 3 file patch

Moves invalid user error from Code to User, where it should be.
Attachment #450972 - Attachment is obsolete: true

Updated

8 years ago
Attachment #450973 - Flags: review?(wurblzap)

Updated

8 years ago
Attachment #450973 - Attachment is obsolete: true
Attachment #450973 - Flags: review?(wurblzap)

Comment 4

8 years ago
Created attachment 451246 [details] [diff] [review]
Moves invalid user error from Code to User, where it should be.

You still get an error, but it's a user error.

Updated

8 years ago
Attachment #451246 - Flags: review?(wurblzap)
(Assignee)

Updated

8 years ago
Attachment #451246 - Flags: review?(wurblzap) → review-
(Assignee)

Comment 5

8 years ago
Comment on attachment 451246 [details] [diff] [review]
Moves invalid user error from Code to User, where it should be.

This error is used at many other places. They must all be fixed.

Comment 6

8 years ago
I thought the idea was to fix bugs as they are reported?
This is the correct fix for this bug.
If there are other errors reporting in the wrong section, then bug reports need to be made so they can be fixed, not ignore one unless the whole section is re-written.
(Assignee)

Comment 7

8 years ago
Your patch breaks all other places. You must fix them all at once.

Comment 8

8 years ago
What are you on about all other places? This is the end path where the error is reported. All it does is change it from a Code error to as User error.
It's only different text on the screen, there's nothing else for it to break.
(Assignee)

Comment 9

8 years ago
This is not the single place which calls 'invalid_user'. All other places throwing this error must also be fixed. Do a grep and look for 'invalid_user'.

Comment 10

8 years ago
Of course it's not the only place that calls invalid_user. Thats why this FIX is at the END, where it does the actual reporting, not on the calling. It fixes ALL calls to invalid_user.

Look at the damn code or don't. I really dont care for all the ****, snobby up themselves devs on this project. You are the reason Open Source projects stagnate and have bugs go unfixed for YEARS.
I'll take my experience elsewhere, where it's appreciated and projects actually get work done on them.
(Assignee)

Comment 11

5 years ago
This is fixed by bug 676844.
Assignee: administration → LpSolit
Severity: normal → minor
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Depends on: 676844
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → FIXED
Whiteboard: [Fixed by blocker]
Target Milestone: --- → Bugzilla 4.4
You need to log in before you can comment on or make changes to this bug.