Bugmail for new bugs without flags contains two unneeded lines

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
Email Notifications
--
trivial
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: reed, Assigned: reed)

Tracking

({regression, ue})

2.23.3
Bugzilla 3.0
regression, ue
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
Bug 365067 fixed an issue with flags set on initial bug creation not being included in the bugmail, but it also caused an annoying problem. Now, all new bug bugmail that does not contain initial flags has two unneeded lines (\n\n) in it. The extra lines should only be added if the bug has flags to show.
(Assignee)

Comment 1

11 years ago
Created attachment 250825 [details] [diff] [review]
patch - v1

Only add the "\n\n" if there is $difftext to display.
Assignee: email-notifications → reed
Status: NEW → ASSIGNED
Attachment #250825 - Flags: review?(LpSolit)

Comment 2

11 years ago
Comment on attachment 250825 [details] [diff] [review]
patch - v1

r=LpSolit
Attachment #250825 - Flags: review?(LpSolit) → review+

Updated

11 years ago
Flags: approval+
(Assignee)

Comment 3

11 years ago
Checking in Bugzilla/BugMail.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/BugMail.pm,v  <--  BugMail.pm
new revision: 1.102; previous revision: 1.101
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.