Unable to install themes or extensions

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Jean-Marie ALLIER, Unassigned)

Tracking

1.8 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/14)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; fr; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; fr; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Theme/Extension install works fine for "root" and standard users but will not for administrators.

Reproducible: Always

Steps to Reproduce:
1.Use tools>addons
2.get an error message
3.check Error Console
Actual Results:  
Here is an example of error console indication after an attempt to install a theme.
Erreur : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsILocalFile.remove]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: file:///Applications/Firefox.app/Contents/MacOS/components/nsExtensionManager.js :: anonymous :: line 4397"  data: no]
Fichier source : file:///Applications/Firefox.app/Contents/MacOS/components/nsExtensionManager.js
Ligne : 4397
An example after an attempt to install an extension
Erreur : uncaught exception: Erreur de sécurité : le contenu situé à https://addons.mozilla.org/firefox/2390/ ne peut pas charger de données à partir de http://releases.mozilla.org/pub/mozilla.org/extensions/videodownloader/videodownloader-1.1.1-fx.xpi.


I tried on 2 different Mac with OS X (10.4.8). One PPC the other Intel.
Theme/Extension Update runs nicely for standard users and root, but do not work for users with administrator rights.
For themes, download is OK but install fails.
For extensions I get an error 228.

I tried after deleting the default profile. I tried with a new profile.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
Version: unspecified → 2.0 Branch
(Reporter)

Comment 2

11 years ago
No change with Firefox 2.0

Comment 3

10 years ago
could you check if hints reported here can help you solving your problem?
http://kb.mozillazine.org/Unable_to_install_themes_or_extensions_-_Firefox
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> could you check if hints reported here can help you solving your problem?
> http://kb.mozillazine.org/Unable_to_install_themes_or_extensions_-_Firefox
> I have not been able to check all hints because I deleted the involved account on my Mac. This account was the only one where downloading/installing themes or extensions did not work. I did some testing on other accounts (admin and standard) and everything works perfectly. So the bug had nothing to do with the fact that the account is an admin account. I set the bug to invalid.


Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Resolution: INVALID → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.