Ctrl-U in text-input copies contents while deleting

VERIFIED FIXED in M16

Status

()

P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: dbaron, Assigned: akkzilla)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+] Have reviewed fix, awaiting checkin approval)

Attachments

(1 attachment)

DESCRIPTION:  Pressing Ctrl-U in a text-input copies the contents of the
text-input before deleting them.  This defeats the point of this shortcut key,
which is designed to allow clearing of a text box without messing up the
clipboard (this is important for X cut&paste).

See bug 7787, bug 16015, and bug 25645 for history of these issues.

STEPS TO REPRODUCE:
 * highlight text in another program to copy
 * type text in URL bar or text input
 * hit control-U
 * middle click in the text input (just cleared) to paste

ACTUAL RESULTS:
 * the text that was cleared from the input is pasted back into it

EXPECTED RESULTS:
 * the text that was copied should be pasted

DOES NOT WORK CORRECTLY ON:
 * Linux, mozilla, 2000-04-20-09-M16

WORKS CORRECTLY ON:
 * NN 4.72 Linux
(Assignee)

Comment 1

19 years ago
This sounds like my bug.  I might need to work with mjudge to come up with a way
of doing this that doesn't trigger the auto-copy-on-select now that that's
implemented.
Assignee: rods → akkana
(Assignee)

Comment 2

19 years ago
Marking M17 in case it turns out to involve selection or editor api changes,
though I hope to get a fix into M16.
Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Reporter)

Comment 3

19 years ago
This bug seems to have gone away...
(Assignee)

Comment 4

19 years ago
*** Bug 36859 has been marked as a duplicate of this bug. ***

Comment 5

19 years ago
Akkana: (I reported the dupe...)
I'm using yesterdays build, 2000042208. This bug seems to have changed into
something worse. Now when i select a normal english sentance and fire up
mozilla, and ^U the location, when i paste, i get garbage. Kanji characters,
some high ascii, a bunch of question marks. If i select (copy) something from
another window, and go back to mozilla, and ^U, then it'll end up pasting part
of the original wierdness. But if i go to an xterm, or something, and paste... I
paste the normal english sentance.

Sometimes, again, i get the original affect, of the whole old location bar being
copied to clipboard. Or sometimes only part of it. Or sometimes double the
original text. I will try again tomarrow or tuesday, work permitting.

Comment 6

19 years ago
I opted to download todays build over sleep.

Still having problems with 20000423, although I can't repeat that spiffy kanji
bug^H^H^Hfeature.
(Assignee)

Comment 7

19 years ago
The Kanji thing is a bug of Pavlov's -- he's asking the clipboard for compound
text instead of normal text.  He says he has a fix in his tree.  It's unrelated
to this bug.

As for this bug, I see it in today's build.  Not sure why dbaron sees it, but I
expect it's still a problem.  I need to come up with a way for turning auto-copy
off temporarily while extending the selection, or else find another way of
deleting to the beginning/end of the line.
(Assignee)

Comment 8

19 years ago
Mike says that batching is supposed to turn off autocopy.  Unfortunately,
batching also makes it impossible to move the selection (nsSelection::TakeFocus
returns NS_ERROR_FAILURE).  Just filed bug 38713 for the underlying issue.
Depends on: 38713
nsbeta2 6/1-. Enabling of correct cut-and-paste between top-level applications.
Keywords: nsbeta2

Comment 10

19 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]

Comment 11

19 years ago
moving to m16
Target Milestone: M17 → M16
(Assignee)

Comment 12

19 years ago
Blocked by 38713, but that bug isn't nsbeta2+.  I've added a comment there.
Whiteboard: [nsbeta2+] → [nsbeta2+] Blocked by 38713
(Assignee)

Comment 13

19 years ago
I have a fix for both this bug and 38713 -- attaching diffs, will test some
more.
Whiteboard: [nsbeta2+] Blocked by 38713 → [nsbeta2+] Have patch, testing now
(Assignee)

Comment 14

19 years ago
Created attachment 9165 [details] [diff] [review]
Patch to fix the problem -- be sure to apply patch for 38713 first

Comment 15

19 years ago
status? can this be checked in? ^U is personal dogfood.
(Assignee)

Comment 16

19 years ago
I hope to check in both of these today, assuming that the tree blockers get
resolved.
(Assignee)

Updated

19 years ago
Whiteboard: [nsbeta2+] Have patch, testing now → [nsbeta2+] Have reviewed fix, awaiting checkin approval
(Assignee)

Comment 17

19 years ago
Fixed!
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 18

19 years ago
Marking VERIFIED FIXED on:
- Linux6 2000-06-01-20-M16 Commercial build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.