memory leaks in DOM Inspector window

RESOLVED WORKSFORME

Status

Other Applications
DOM Inspector
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: tonymec, Unassigned)

Tracking

({memory-leak})

1.8 Branch
memory-leak

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2pre) Gecko/20070101 BonEcho/2.0.0.2pre
Build Identifier: "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2pre) Gecko/20070101 BonEcho/2.0.0.2pre" - Build ID: 2007010104

see attachment, as produced by Leak Monitor 0.3.6 when I clicked on the top-right X button to close the DOMi window

Reproducible: Didn't try

Actual Results:  
memory leaks

Expected Results:  
no memory leaks

see attachment, which I'll add as soon as I get the option
Created attachment 250153 [details]
memory leak report

produced by Leak Monitor 0.3.6
Keywords: mlk
Version: unspecified → 1.8 Branch
Can you get a leak report with a clean profile (only DOMI installed)?  I'm seeing a lot of leaks from other exensions, and there are a few objects that the DOMI may be leaking, but I cannot be sure.
(In reply to comment #2)
> Can you get a leak report with a clean profile (only DOMI installed)?  I'm
> seeing a lot of leaks from other exensions, and there are a few objects that
> the DOMI may be leaking, but I cannot be sure.
> 

DOMi and Talkback are part of the distribution; but of course I'd have to have at least Leak Monitor installed. I'll try to do it, starting Firefox with

   firefox -no-remote -ProfileManager &

at the bash prompt. Any results will be reported here.
<shrug /> Couldn't reproduce it with only the distributed components + Leak Monitor.

Note: the chrome URI above was entered in the DOMi input box between the spyglasses and the [ Inspect ] button, not in the Location Bar in the main browser window. In the original case, it had caused a strange popup from Tab Mix Plus, which seemed to believe we were restarting from a crash.
> Note: the chrome URI above was entered in the DOMi input box between the
> spyglasses and the [ Inspect ] button, not in the Location Bar in the main
> browser window. In the original case, it had caused a strange popup from Tab
> Mix Plus, which seemed to believe we were restarting from a crash.

What chrome uri did you enter?

I think those leaks were from other extensions (I saw a lot of entries from two of them at least).
(In reply to comment #5)
> What chrome uri did you enter?

As shown under "URI" here at top, chrome://browser/content/browser.xul
Do you get those leaks when you close out the browser window normally too, or no? I would think that you would, but I'm curious.
(In reply to comment #7)
> Do you get those leaks when you close out the browser window normally too, or
> no? I would think that you would, but I'm curious.
> 

No I don't. In fact I only got that alert that one time, and I install the 1.8.1-branch nightlies every day.
Based on the leak results, nothing seems to be caused by DOMi, so I think this bug might be RESOLVED INVALID

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Assignee: dom-inspector → nobody
QA Contact: timeless → dom-inspector
You need to log in before you can comment on or make changes to this bug.