Closed Bug 365661 Opened 13 years ago Closed 13 years ago

Customize toolbar throws exception with AdBlockPlus installed

Categories

(Firefox :: Toolbars and Customization, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 363383

People

(Reporter: By-Tor, Unassigned)

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070102 Minefield/3.0a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070102 Minefield/3.0a2pre

With Minefield and AdBlockPlus 0.7.2.3 installed, if I try to customize the toolbar, I'll get an empty window - no icons - and the following exception in the Error Console:

Error: uncaught exception: [Exception... "Illegal operation on WrappedNative prototype object"  nsresult: "0x8057000c (NS_ERROR_XPC_BAD_OP_ON_WN_PROTO)"  location: "JS frame :: chrome://global/content/customizeToolbar.js :: setWrapperType :: line 438"  data: no] 

Reproducible: Always

Steps to Reproduce:
1. Install AdBlockPlus
2. Try to customize toolbar
3.
Actual Results:  
Dialog without icons appears.

Expected Results:  
Should be able to customize toolbar as normal.

Not sure if this is a bug in AdBlockPlus or Minefield, but thought it was worth mentioning.
Keywords: regression
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 363383
You need to log in before you can comment on or make changes to this bug.