Enabling calendar via checkbox immediately disables after first click

RESOLVED WORKSFORME

Status

Calendar
General
--
minor
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.9a2pre) Gecko/20070102 Calendar/0.4a1 - Build ID: 2007010203

Used SQL-based locale storage.
Works with second click (but now calendar had focus / was selected).

Reproducible: Always

Steps to Reproduce:
1.Disable a calendar
2.Click on another one
3.Click on the checkbox of the disabled calendar.

Actual Results:  
checkbox toggled on and immediately off.

Expected Results:  
checkbox only toggled on

Comment 1

11 years ago
I can confirm this also on mac OS X 10.4.8
Sunbird Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a2pre) Gecko/20070102 Calendar/0.4a1

Sunbird Build ID: 2007010203

On the mac, you don't see the checkbox get checked then unchecked.  There, you click on the checkbox, and it remains unchecked.

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Updated

11 years ago
Summary: Enabling calendar immediatley disable it on first click → Enabling calendar via checkbox immediately disables after first click

Comment 2

11 years ago
I'd like to see this bug retested tomorrow, since bug #350323 has been backed out.

Comment 3

11 years ago
This issue was caused by the checkin for Bug 350323 that was backed out, see Bug 350323 Comment #19
As I understand comment#2 and comment#3 this bug should be resolved because the causing patch was backed out. Archaeopteryx, do you agree with me?
Seems fixed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6pre) Gecko/20070723 Calendar/0.7pre
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.