Delete item in History sidebar seems to collapse tree view

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Warner Young, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Created attachment 250185 [details]
History treeview after deleting an item

When I delete an item in the History sidebar (sorted "By Date and Site"), Minefield acts like the treeview has been collapsed.  However, the selected color highlight is still in the same place it was before, and the scrollbar still behaves like all the entries are open (screenshot attached).  Items are correctly deleted, but the treeview must be re-opened each time, and the scrollbar gets longer and longer each time.

I've been seeing this since the "Gecko/20061230 Minefield/3.0a2pre" build, and still seeing it on Gecko/20070102 Minefield/3.0a2pre.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070102 Minefield/3.0a2pre
FWIW, I can't reproduce your screenshot. Using a normal hourly (no places).
I've seen this bug, too.
(Reporter)

Comment 3

12 years ago
Ria Klassen, I don't believe I'm using a Places-enabled build.  I'm downloading the nightlies pointed to by the MozillaZine Firefox forums.  How do I check if Places is enabled?
I guess if you did build it, it is non-places :?
(In reply to comment #4)
> I guess if you did build it, it is non-places :?
>
I guess if you didn't build it, it is non-places. Typo, sorry. 

if you are using the trunk, then you are using the history sidebar based on places.
(Reporter)

Comment 7

12 years ago
In that case, possibly related to bug 364110?
Component: History → Places
QA Contact: history → places

Comment 8

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070409 Minefield/3.0a4pre - Build ID: 2007040907, XP, bookmarks-on-places-enabled:

WFM
(Reporter)

Comment 9

11 years ago
Agreed.  Seems to be WFM now on latest trunk.
Ok, in that case, I'm marking this bug worksforme.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.