Scoll wheel broken when mouse is over elements with CSS position:fixed set.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Ken Burwood, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

When you have elements with CSS position:fixed set and you place the mouse cursor over one of these elements, the scroll wheel will not scroll the page.  Place the cursor over any other part of the page, and the scroll wheel works fine.  This appears to happen with any element--tested with span, div, p and table.

Example element: <span style="position:fixed;">Floating SPAN</span>

Reproducible: Always

Steps to Reproduce:
1. Load any long page with a floating element, as above
2. Place mouse cursor over the element
3. Attempt to scroll with scroll wheel
Actual Results:  
Document doesn't scroll.

Expected Results:  
Document should scroll.
(Reporter)

Comment 1

12 years ago
Created attachment 250205 [details]
Test case with four fixed elements.
First I could not reproduce the problem but it was SmoothWheel playing me tricks.
This problem is fixed-on-trunk somewhere in the first few months of 2006. You can try it out:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
I'll resolve this bug WFM unless or until someone knows what bug fixed this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.